1066. Root of AVL Tree (25)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

    

    

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print ythe root of the resulting AVL tree in one line.

Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:

88

考察AVL树的基本操作,AC代码:

#include<iostream>
using namespace std;

struct treeNode
{
	int val;
	treeNode* left;
	treeNode* right;
};

treeNode* rotateLL(treeNode* root)
{
	treeNode* child = root->left;
	treeNode* temp = child->right;
	child->right = root;
	root->left = temp;
	return child;
}

treeNode* rotateRR(treeNode* root)
{
	treeNode* child = root->right;
	treeNode* temp = child->left;
	child->left = root;
	root->right = temp;
	return child;
}

treeNode* rotateLR(treeNode* root)
{
	root->left = rotateRR(root->left);
	return rotateLL(root);
}

treeNode* rotateRL(treeNode* root)
{
	root->right = rotateLL(root->right);
	return rotateRR(root);
}

int getHeight(treeNode* root)
{
	if(root == NULL)
		return 0;
	else
		return max(getHeight(root->left) + 1, getHeight(root->right) + 1);
}

bool isBalance(treeNode* root)
{
	return abs(getHeight(root->left) - getHeight(root->right)) < 2;
}

treeNode* insert(treeNode* root, int val)
{
	if(root == NULL)
	{
		root =new treeNode();
		root->val = val;
		return root;
	}
	if(val <= root->val)
	{
		root->left = insert(root->left, val);
		if(!isBalance(root))
		{
			if(val <= root->left->val)
			{
				root = rotateLL(root);
			}
			else
			{
				root = rotateLR(root);
			}
		}
	}
	else
	{
		root->right = insert(root->right, val);
		if(!isBalance(root))
		{
			if(val > root->right->val)
			{
				root = rotateRR(root);
			}
			else
			{
				root = rotateRL(root);
			}
		}
	}
	return root;
}

int main()
{
	int n;
	scanf("%d", &n);
	treeNode* root = NULL;
	for(int i = 0; i < n; i++)
	{
		int val;
		scanf("%d", &val);
		root = insert(root, val);
	}
	printf("%d",root->val);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值