PAT--1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0
#include <iostream>
#include <bits/stdc++.h>
#include <cstdio>
using namespace std;
const int maxn = 1100;

int G[maxn][maxn];
int n,m,k;
bool visit[maxn];

void DFS(int u)
{
    visit[u] = true;
    for(int v=1; v<=n; v++)
    {
        if(visit[v]==false && G[u][v]==1)
        {
            DFS(v);
        }
    }
}
int main()
{
    scanf("%d %d %d",&n,&m,&k);

    //memset(G,0,sizeof(G));
    //fill(G[0],G[0]+maxn*maxn,0);
    int a,b;
    for(int i=1; i<=m; i++)
    {
        scanf("%d %d",&a,&b);
        G[a][b] = 1;
        G[b][a] = 1;
    }

    int vode;
    for(int i=0; i<k; i++)
    {
        fill(visit,visit+1000,false);
        scanf("%d",&vode);

        visit[vode]= true;
        int counts = 0;
        for(int j=1; j<=n; j++)
        {
            if(visit[j]==false)
            {
                DFS(j);
                counts++;
            }

        }

        printf("%d\n",counts-1);

    }
    //cout << "Hello world!" << endl;
    return 0;
}

 思路:

本题就是分析其原有图删除一个结点之后,判断其联通分量的数目,其需要的路数就是连通分量数-1;

其题目中“被敌人占有的城市”,就是在DFS之外将其设为已访问(visit置1),然后在DFS剩下的结点,判断其连通分量数。例如:1 2 3城市中,1被设为已访问,则剩下的联通分量数就变为2,需添加一条路来连通它们

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值