PAT - A1013 Battle Over Cities 迪杰斯特拉求连通分量

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目大意

若干个城市之间有若干条道路。如果某个城市被敌人攻占,那么通向该城市的道路就被关闭。为了使剩余所有的城市连通,求还需要建设几条道路。

思路

典型的dfs染色法求连通分量,被敌人攻占的城市相当于已被染色。

推荐阅读:djs 染色法求联通分量


Vector保存树

#include <iostream>
#include <vector>
#include <cstdio>
using namespace std;
#define maxN 1001
bool marked[maxN];
vector<int> graph[maxN];
void dfs(int v){
    marked[v] = true;
    for(auto lt = graph[v].cbegin(); lt != graph[v].cend(); lt++){
        if(!marked[*lt]){
            dfs(*lt);
        }
    }
}
int main() {
    int n, m, k;
    scanf("%d %d %d", &n, &m, &k);
    int u, v;
    while (m-- > 0) {
        scanf("%d %d", &u, &v);
        graph[v].push_back(u);
        graph[u].push_back(v);
    }
    int t;
    for(int i = 0; i < k; i++){
        scanf("%d", &t);
        fill(marked, marked + maxN, false);
        // 将被攻占的城市标记为已访问
        marked[t] = true;
        int count = 0;
        for(int v = 1; v <= n; v++){
            if(marked[v] == false){
                dfs(v);
                count++;
            }
        }
        printf("%d\n", count - 1);
    }
    return 0;
}

数组保存树:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int maxnum=1001;
int color[maxnum];
int map[maxnum][maxnum];
void dfs(int v,int n){
	color[v]=1;
	for(int j=1;j<=n;j++){
		if(!color[j]&&map[v][j]){     //数组保存树的遍历和vector的唯一区别就在这里,这里的判 
                                      //断,需要判断下一个节点是否连通。而因为vector数组储存                    
                                      //树的方式(只储存自己的孩子),所以无需判断
			dfs(j,n);
		}
	}
}
int main(){
	int a,b,c,d,e;
	scanf("%d %d %d",&a,&b,&c);
	fill(map[0],map[0]+maxnum*maxnum,0);
	while(b--){
		scanf("%d %d",&d,&e);
		map[d][e]=1;
		map[e][d]=1;
	}
	
	while(c--){
		scanf("%d",&d);
		fill(color,color+maxnum,0);
		color[d]=1;
		e=0;
		for(int i=1;i<=a;i++){
			if(!color[i]){
				dfs(i,a);
				e++;
			}
		}
		printf("%d\n",e-1);
	}
return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值