POJ 3461

Oulipo

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 29195 Accepted: 11701

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
        这道题的目的是两字符串的匹配,同时找出短串在长串中重复的个数(每次数之间可以共用字符)。这提示我们使用kmp算法可以高效地得到结果。基本上套用一般模板就可以了,要注意的是在kmp过程中一旦到达短串的长度要记录加一,最后的记录个数就是答案。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int T,A,B;
int num;
int nxt[10010];
char a[10010],b[1000010];
void getnxt(){
	int j,k;
	j=0;k=-1;nxt[0]=-1;
	while(j<A){
		if(k==-1||a[j]==a[k]){
			nxt[++j]=++k;
		}else{
			k=nxt[k];
		}
	}
}//得到next数组
void kmp(){
	int j,k;
	j=0;k=0;
	while(j<B){
		if(k==-1||a[k]==b[j]){
			++k;++j;
		}else{
			k=nxt[k];
		}
		if(k==A){
			num++;
			k=nxt[k];
		}//表明找到了对应字段,记录加一
	}
}
int main(){
	scanf("%d",&T);
	while(T--){
		num=0;
		scanf("%s",a);
		scanf("%s",b);
		A=strlen(a),B=strlen(b);
		getnxt();
		kmp();
		printf("%d\n",num);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值