The Blocks Problem ——Uva 101

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies.For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robotarm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Ratherthan determine how to achieve a speci ed state, you will “program” a robotic arm to respond to alimited set of commands.

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocksthat lie on a at table. Initially there are n blocks on the table (numbered from 0 to n 1) with blockbi adjacent to block bi+1 for all 0 i < n 1 as shown in the diagram below:

Initial Blocks World
The valid commands for the robot arm that manipulates blocks are:

  • move a onto b
    where a and b are block numbers, puts block a onto block b after returning any blocks that are

    stacked on top of blocks a and b to their initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing block b, afterreturning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocksthat are stacked above block a, onto block b. All blocks on top of block b are moved to theirinitial positions prior to the pile taking place. The blocks stacked above block a retain their orderwhen moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocksthat are stacked above block a, onto the top of the stack containing block b. The blocks stackedabove block a retain their original order when moved.

  • quit
    terminates manipulations in the block world.

    Any command in which a = b or in which a and b are in the same stack of blocks is an illegalcommand. All illegal commands should be ignored and should have no a ect on the con guration ofblocks.

    Input

    The input begins with an integer n on a line by itself representing the number of blocks in the blockworld. You may assume that 0 < n < 25.

    The number of blocks is followed by a sequence of block commands, one command per line. Yourprogram should process all commands until the quit command is encountered.

    You may assume that all commands will be of the form speci ed above. There will be no syntacticallyincorrect commands.

    Output

    The output should consist of the nal state of the blocks world. Each original block position numberedi (0 i < n where n is the number of blocks) should appear followed immediately by a colon. If thereis at least a block on it, the colon must be followed by one space, followed by a list of blocks that appearstacked in that position with each block number separated from other block numbers by a space. Don’tput any trailing spaces on a line.

    There should be one line of output for each block position (i.e., n lines of output where n is theinteger on the rst line of input).

    Sample Input

    10
    move 9 onto 1
    move 8 over 1
    move 7 over 1
    move 6 over 1
    pile 8 over 6
    pile 8 over 5
    move 2 over 1
    move 4 over 9
    quit
    

    Sample Output

     0: 0
     1: 1 9 2 4
     2:
     3: 3
     4:
     5: 5 8 7 6
     6:
     7:
     8:
     9:
    
    
    

本题的反思:

    这道题虽然不难,但是如果想要完整地做出来,对我来说还有一些难度。。。毕竟懒人天性不是这么容易改好的。。。。。。

主要困住我的一个思维点在于,怎么保存下当前的方块的高度和每一个高度对应的数字。感觉好麻烦啊。。。(再次暴露懒人天性)其实很简单啊,直接使用vector就可以解决的事情。。。。。。

    

所以来看书上的标准答案:

#include<iostream>
#include<cstdio>
#include<vector>
#include<string>
using namespace std;

const int maxn = 30;
int n;
vector<int> pile[maxn];//每个pile[i]是一个vector

//找木块a所在的pile和height,以引用的形式返回调回者
void find_block(int a, int& p, int &h)
{
    for(p = 0; p < n; p++)
        for(h = 0; h < pile[p].size(); h++)
            if(pile[p][h] == a)
                return ;
}

//把第p对高度为h的木块上方的所有木块移回原位
void clear_above(int p, int h)
{
    for(int i = h+1; i < pile[p].size(); i++)
    {
        int b = pile[p][i];
        pile[b].push_back(b);//把木块b放回原位
    }
    pile[p].resize(h+1);//pile只应该保留下标0~h的元素
}

//把第p堆高度为h及其上方的木块整体移动到p2堆的顶部
void pile_onto(int p, int h, int p2)
{
    for(int i = h; i < pile[p].size(); i++)
        pile[p2].push_back(pile[p][i]);
    pile[p].resize(h);
}

void print()
{
    for(int i = 0; i < n; i++)
    {
        printf("%d:", i);
        for(int j = 0; j < pile[i].size(); j++)
            printf(" %d", pile[i][j]);
        printf("\n");
    }
}

int main(){
    int a, b;
    cin >> n;
    string s1, s2;
    for(int i = 0; i < n; i++)
        pile[i].push_back(i);
    while(cin >> s1 >> a >> s2 >> b)
    {
        int pa, pb, ha, hb;
        find_block(a, pa, ha);
        find_block(b, pb, hb);
        if(pa == pb)
            continue;
        if(s2 == "onto")
            clear_above(pb, hb);
        if(s1 == "move")
            clear_above(pa, ha);
        pile_onto(pa, ha, pb);
    }
    print();
	return 0;
}

书上代码中有许多值得学习的地方,就好比:

1、对于输入。cin>>s1>>a>>s2>>b,这一个我当时看到题目的时候一脸懵逼......怎么想就是没有想起来......(其实想想啊,cin>>string也并不支持带空格的输入啊......)

2、有关于那四种放法。我原来想的是用switch......然后一想好麻烦......四种情况,每种都几乎有相当一部分的重复......

    那为啥不用函数啊QAQ......用函数抽象出每种放法的共同点,这样的话直接调用又简单又方便。学到了。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值