Andy's First Dictionary ——Uva 10815

Andy, 8, has a dream - he wants to produce hisvery own dictionary. This is not an easy task forhim, as the number of words that he knows is,well, not quite enough. Instead of thinking up allthe words himself, he has a briliant idea. Fromhis bookshelf he would pick one of his favouritestory books, from which he would copy out allthe distinct words. By arranging the words inalphabetical order, he is done! Of course, it isa really time-consuming job, and this is where acomputer program is helpful.

You are asked to write a program that lists
all the different words in the input text. In this
problem, a word is defined as a consecutive se-
quence of alphabets, in upper and/or lower case.
Words with only one letter are also to be considered. Furthermore, your program must be CaSe In-SeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Inputis terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. Thewords should all be in lower case, sorted in alphabetical order. You can be sure that he number ofdistinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."
So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

本题分析:

    简单题,用set数据结构即可求解——每个元素最多只出现一次,并且set中元素已经从小到大排好序。用for循环即可从小到大遍历所有元素。

    

本题其他知识点——sstream

  • sstream多定义的类型用于读写存储在内存中的string对象。


本题的代码(参考书中代码):

#include<iostream>
#include<set>
#include<string>
#include<sstream>
using namespace std;

set<string> dict; //string集合

int main(){
    string s, buf;
    while(cin>>s)
    {
        for(int i = 0; i < s.length(); i++)
            if(isalpha(s[i]))
                s[i] = tolower(s[i]);
            else 
                s[i] = ' ';
        stringstream ss(s);
        while(ss >> buf)
            dict.insert(buf);
    }
    for(set<string>::iterator it = dict.begin(); it != dict.end(); ++it)
        cout << *it << "\n";
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值