Ananagrams——Uva 156

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in di erentorders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have thisattribute, no matter how you rearrange their letters, you cannot form another word. Such words arecalled ananagrams, an example is QUIZ.

Obviously such de nitions depend on the domain within which we are working; you might thinkthat ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possibledomain would be the entire English language, but this could lead to some problems. One could restrictthe domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in thesame domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relativeananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be“rearranged” at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain anynumber of words. Words consist of up to 20 upper and/or lower case letters, and will not be brokenacross lines. Spaces may appear freely around words, and at least one space separates multiple wordson the same line. Note that words that contain the same letters but of di ering case are considered tobe anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The le will be terminated by a lineconsisting of a single ‘#’.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagramin the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will alwaysbe at least one relative ananagram.

Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample Output

Disk
NotE
derail
drIed
eye
ladder
soon

本题分析:

    这道题如果不使用stl的话感觉会很麻烦。不过思路上应该是将每一个单词先存在一个数组中,然后对每一个单词进行字母的排序,如果有相同的,那么就删掉,否则保存下来。


#include<iostream>
#include<string>
#include<map>
#include<cctype>
#include<vector>
#include<algorithm>
using namespace std;

map<string, int> cnt;
vector<string> words;

//将单词s进行“标准化”
string repr(const string& s)
{
    string ans = s;
    for(int i = 0; i < ans.length(); i++)
        ans[i] = tolower(ans[i]);
    sort(ans.begin(), ans.end());//sort也可以这样使用的,注意理解string的用法,它是一个类
    return ans;
}

int main(){
    int n = 0;
    string s;
    while(cin >> s)
    {
        if(s[0] == '#')
            break;
        words.push_back(s);//存在words中的是原来输入的词。
        string r = repr(s);//存在r中的是这个词经过小写和排序变换之后的词
        if(!cnt.count(r))//使用了count()函数。
            cnt[r] = 0;//如果没有找到这个字符,那么就把cnt[r]置为0。这里考虑,如果没有找到,那么不进行操作。实际上cnt存储的是单词出现的次数
        cnt[r]++;
    }
    vector<string> ans;
    for(int i = 0; i < words.size(); i++)
        if(cnt[repr(words[i])] == 1)//如果出现了1次
            ans.push_back(words[i]);
    sort(ans.begin(), ans.end());
    for(int i = 0; i < ans.size(); i++)
        cout << ans[i] << "\n";
	return 0;
}

count函数:使用一对迭代器和一个值作为参数,返回这个值出现的次数作为结果。


此外在网上看到了另外一种相似的做法,没有用stl。具体的是:UVA 156 Ananagrams 模拟+字符串处理


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值