51NOD 1080 两个数的平方和

链接: https://www.51nod.com/onlineJudge/questionCode.html#!problemId=1080

1080 两个数的平方和

基准时间限制:1 秒
空间限制:131072 KB
分值: 5
难度:1级算法题

关键词: 数论 -> 构造

Description

给出一个整数N,将N表示为2个整数i j的平方和(i <=j),如果有多种表示,按照i的递增序输出。 例如:N = 130,130 = 3^2 + 11^2 = 7^2 + 9^2 (注:3 11同11 3算1种)

Input

一个数N(1 <= N <= 10^9)

Output

共K行:每行2个数,i j,表示N = i^2 + j^2(0 <= i <= j)。 如果无法分解为2个数的平方和,则输出No Solution

SampleInput

130

SampleOutput

3 11
7 9

Code1

#include <cstdio>  
#include <cstring>  
#include <algorithm>  
#include <iostream>  
#include <map>  
#include <cmath>  
using namespace std;  
#define LL long long  
  
map <LL ,LL >ans;  
  
LL mod_pow(LL a, LL b)  
{  
    LL ans = 1;  
    while(b)  
    {  
        if(b&1) ans = ans*a;  
        a = a * a;  
        b >>= 1;  
    }  
    return ans;  
}  
void init()  
{  
    ans.clear();  
    for(int i=0; i<=40000; i++)  
    {  
        ans[mod_pow(i, 2)] = i+1;  
        //cout << ans[mod_pow(i,2)]<<endl;  
    }  
}  
int main()  
{  
  
    LL n;  
    init();  
    //cout << mod_pow(40000, 2) << endl;  
    while(cin >> n)  
    {  
        bool flag = false;  
        for(int i=0; mod_pow(i,2)<=n; i++){  
            if(ans[n-mod_pow(i,2)]) {  
                flag = true;  
                if(i <= ans[n-mod_pow(i,2)]-1)  
                    cout << i <<" " << ans[n-mod_pow(i,2)]-1<<endl;  
                else  
                    break;  
            }  
        }  
        if(!flag)  
            cout << "No Solution" << endl;  
    }  
  
  
    return 0;  
}

Code2

#include <iostream>  
#include <cmath>  
using namespace std;  
int main()  
{  
    int n,k,m,i,j;  
    cin >> n;  
    m = sqrt(n+0.5);  
    k = 0;  
    for(i=0; i<=m; i++) {  
        j = sqrt(n-i*i);  
        if(j*j + i*i == n && j >= i)    {  
            k=1;cout<<i<<" "<<j<<endl;  
        }  
    }  
    if(!k)  
        cout<<"No Solution"<<endl;  
    return 0;  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值