Cornfields
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 7110 | Accepted: 3465 |
Description
FJ has decided to grow his own corn hybrid in order to help the cows make the best possible milk. To that end, he's looking to build the cornfield on the flattest piece of land he can find.
FJ has, at great expense, surveyed his square farm of N x N hectares (1 <= N <= 250). Each hectare has an integer elevation (0 <= elevation <= 250) associated with it.
FJ will present your program with the elevations and a set of K (1 <= K <= 100,000) queries of the form "in this B x B submatrix, what is the maximum and minimum elevation?". The integer B (1 <= B <= N) is the size of one edge of the square cornfield and is a constant for every inquiry. Help FJ find the best place to put his cornfield.
FJ has, at great expense, surveyed his square farm of N x N hectares (1 <= N <= 250). Each hectare has an integer elevation (0 <= elevation <= 250) associated with it.
FJ will present your program with the elevations and a set of K (1 <= K <= 100,000) queries of the form "in this B x B submatrix, what is the maximum and minimum elevation?". The integer B (1 <= B <= N) is the size of one edge of the square cornfield and is a constant for every inquiry. Help FJ find the best place to put his cornfield.
Input
* Line 1: Three space-separated integers: N, B, and K.
* Lines 2..N+1: Each line contains N space-separated integers. Line 2 represents row 1; line 3 represents row 2, etc. The first integer on each line represents column 1; the second integer represents column 2; etc.
* Lines N+2..N+K+1: Each line contains two space-separated integers representing a query. The first integer is the top row of the query; the second integer is the left column of the query. The integers are in the range 1..N-B+1.
* Lines 2..N+1: Each line contains N space-separated integers. Line 2 represents row 1; line 3 represents row 2, etc. The first integer on each line represents column 1; the second integer represents column 2; etc.
* Lines N+2..N+K+1: Each line contains two space-separated integers representing a query. The first integer is the top row of the query; the second integer is the left column of the query. The integers are in the range 1..N-B+1.
Output
* Lines 1..K: A single integer per line representing the difference between the max and the min in each query.
Sample Input
5 3 1 5 1 2 6 3 1 3 5 2 7 7 2 4 6 1 9 9 8 6 5 0 6 9 3 9 1 2
Sample Output
5
Source
可以用二维RMQ,也可以直接暴力,暴力有点小思维,因为直接暴力,无论初始记录每个点对应的解还是查询时暴力都会t,其实只需要对于每个点,记录他此行b长度内的最值,然后查询时O(b)遍历一遍列就好了
#include<stdio.h>
int main()
{
int n,a[300][300],maxa[300][300],mina[300][300],b,t,k,i,j,x,y,max,min;
scanf("%d %d %d",&n,&b,&t);
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&a[i][j]);
for(k=0;k<n;k++)
for(i=0;i<n;i++)
{
max=min=a[k][i];
for(j=i;j<i+b&&j<n;j++)
{
if(a[k][j]>max)
max=a[k][j];
if(a[k][j]<min)
min=a[k][j];
}
maxa[k][i]=max;
mina[k][i]=min;
}
while(t--)
{
scanf("%d %d",&x,&y);
x--,y--;
max=min=a[x][y];
for(i=x;i<x+b;i++)
{
if(maxa[i][y]>max)
max=maxa[i][y];
if(mina[i][y]<min)
min=mina[i][y];
}
printf("%d\n",max-min);
}
return 0;
}