POJ - 1159 Palindrome 最长公共子序列

Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 61919   Accepted: 21576

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source


不难想就是求最长回文子序列长度,之前听别人讨论过最长回文子序长度的求法,是字符本身与它的逆序字符的最长公共子序列长度

例如  abbac

也就是求abbac 与cabba的最长公共子序列

写了一发超内存了,改了改才过了

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<set>
typedef long long ll;
using namespace std;
int dp[3][5005];
int main()
{ 
	int i,j,n;
	char ch[5005],ch1[5005];
	scanf("%d",&n);
	getchar();
	scanf("%s",ch+1);
	for(i=1;i<=n;i++)
	ch1[n-i+1]=ch[i];
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			if(ch[i]==ch1[j])
			{
				dp[1][j]=dp[0][j-1]+1;
			}
			else
			dp[1][j]=max(dp[0][j],dp[1][j-1]);
		}
		for(j=1;j<=n;j++)
		dp[0][j]=dp[1][j];
	}
	printf("%d\n",n-dp[1][n]);
	return 0; 
 }



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值