ZOJ 3954 Seven-Segment Display

Seven-Segment Display

Time Limit: 1 Second       Memory Limit: 65536 KB

A seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays. Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.

The segments of a seven segment display are arranged as a rectangle of two vertical segments on each side with one horizontal segment on the top, middle, and bottom. If we refer the segments as the letters from a to g, it's possible to use the status of the segments which is called a seven segment code to represent a number. A standard combination of the seven segment codes is shown below.

Xabcdefg
11001111
20010010
30000110
41001100
50100100
60100000
70001111
80000000
90000100
   
0 = on  1 = off

A seven segment code of permutation p is a set of seven segment code derived from the standard code by rearranging the bits into the order indicated by p. For example, the seven segment codes of permutation "gbedcfa" which is derived from the standard code by exchanging the bits represented by "a" and "g", and by exchanging the bits represented by "c" and "e", is listed as follows.

Xgbedcfa
11011011
20000110
30010010
40011001
50110000
60100000
71011010
80000000
90010000

We indicate the seven segment code of permutation p representing number x as cpx. For example cabcdefg,7 = 0001111, and cgbedcfa,7 = 1011010.

Given n seven segment codes s1s2, ... , sn and the numbers x1x2, ... , xn each of them represents, can you find a permutation p, so that for all 1 ≤ i ≤ nsi = cpxi holds?

Input

The first line of the input is an integer T (1 ≤ T ≤ 105), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 ≤ n ≤ 9), indicating the number of seven segment codes.

For the next n lines, the i-th line contains a number xi (1 ≤ xi ≤ 9) and a seven segment code si (|si| = 7), their meanings are described above.

It is guaranteed that ∀ 1 ≤ i < j ≤ nxi ≠ xj holds for each test case.

Output

For each test case, output "YES" (without the quotes) if the permutation p exists. Otherwise output "NO" (without the quotes).

Sample Input
3
9
1 1001111
2 0010010
3 0000110
4 1001100
5 0100100
6 0100000
7 0001111
8 0000000
9 0000100
2
1 1001111
7 1010011
2
7 0101011
1 1101011
Sample Output
YES
NO
YES
Hint

For the first test case, it is a standard combination of the seven segment codes.

For the second test case, we can easily discover that the permutation p does not exist, as three in seven bits are different between the seven segment codes of 1 and 7.

For the third test case, p = agbfced.

在给出查询之后,按列去考虑,因为无论怎么置换,每一列上的排列情况是不会变的,我们可以把这一列看为一个二进制数,

在给出查询后,其实只需要考虑需要查询的那些行,所以把不需要查询的行去掉即可

然后在根据每一列求出一个二进制数,如果所有列形成的集合和原序列所有列形成的集合是完全相同的(这里的集合不考虑列的先后顺序),则YES

就像第二个样例

只需要看第一行和第七行

原序列

1  : 1 0 1 1 0 1 1 

7  : 1 0 1 1 0 1 0

 他形成的集合就是

          2 0 2 2 0 2 1

给定的查询

1  :  1 0 0 1 1 1 1

7  :  1 0 1 0 0 1 1

形成的集合就是

     2 0 1 1 1 2 2

很明显这两个集合是不同的,所以答案是NO

而对于第三个样例

 两个集合是相等的

仔细想想真的好水啊。。。。。

#include<bits/stdc++.h>
using namespace std;
map<int,int >Q;
int a[10][8]={
0,0,    0,  0,  0,  0,  0,  0,
0,1,	0,	0,	1,	1,	1,	1,
0,0,	0,	1,	0,	0,	1,	0,
0,0,	0,	0,	0,	1,	1,	0,
0,1,	0,	0,	1,	1,	0,	0,
0,0,	1,	0,	0,	1,	0,	0,
0,0,	1,	0,	0,	0,	0,	0,
0,0,	0,	0,	1,	1,	1,	1,
0,0,	0,	0,	0,	0,	0,	0,
0,0,	0,	0,	0,	1,	0,	0
};
int b[10][8];
int c[10];
int main(){
	int i,j;
	int t;
	int n;
	char cc;
	int num;
	bool flag;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d ",&(c[i]));
			for(int j=1;j<=7;j++)
            {
                scanf("%c",&cc);
                b[c[i]][j]=(cc-'0');
			}
		}
		sort(c,c+n);
		Q.clear();
		flag=true;
		for(i=1;i<=7;i++)
		{
			num=0;
            for(j=0;j<n;j++)
            {
                num<<=1;
                num+=a[c[j]][i];
            }
            Q[num]++;
//		    printf("%d%c",num," \n"[i==7]);
		}
		for(i=1;i<=7;i++)
		{
			num=0;
            for(j=0;j<n;j++)
            {
                num<<=1;
                num+=b[c[j]][i];
            }
            if( Q.count(num )==0 )
            {
                flag=false;
                break;
            }
            Q[num]--;
            if(Q[num]<0)
            {
                flag=false;
                break;
            }
	//	printf("%d%c",num," \n"[i==7]);
		}
		if(flag) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值