【PAT】A1075 PAT Judge (25分)---排序

2 篇文章 0 订阅

做题笔记:

这道题题目条件逻辑关系还是比较多的:

  • 首先结构体定义好
struct node
{
	int id;
	int score[6];
	int sum;  //总分
	int num;  //满分数
	bool flag; //是否有过有效提交
	node(){
		memset(score, -1, sizeof(score));//初始分数为-1
		sum = 0;
		num = 0;
		flag = false;
	}
	
}stu[maxn];
  • 再是几点注意点,题目逻辑:
  1. 全部题都无提交记录或没有一题通过编译的,都是不给排名的flag = false ;这些选手一律不排名不输出。
  2. 无提交记录的题输出为"-";
  3. 有提交记录但没通过编译的,题目分数为0 不再是-1(输出不再是"-"
  4. 有有效提交记录(通过编译的),flag = true.

1075 PAT Judge (25分)

题目链接

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10^4
​​ ), the total number of users, K (≤5), the total number of problems, and M (≤10^​5
​​ ), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

AC代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int const maxn = 10010;

struct node
{
	int id;
	int score[6];
	int sum;  //总分
	int num;  //满分数
	bool flag; //是否有过有效提交
	node(){ //不写构造函数 放在init()里一起初始化也可
		memset(score, -1, sizeof(score));
		sum = 0;
		num = 0;
		flag = false;
	}

}stu[maxn];

void init(int n){
	for(int i=0; i<=n; i++){
		stu[i].id = i;
	}
}
bool cmp(node A, node B){
    if(A.flag!=B.flag) return A.flag>B.flag;
	else if(A.sum!=B.sum) return A.sum>B.sum;
	else if(A.num!=B.num) return A.num>B.num;
	else return A.id<B.id;
}
int main()
{
	int n,k,m;
	int p[6] = {0}; //题目对应的满分分数
	scanf("%d%d%d",&n,&k,&m);
	init(n);
	for(int i=1; i<=k; i++){
		scanf("%d",&p[i]);
	}

	for(int i=0; i<m; i++){

		int u_id, p_id, sco;
		scanf("%d%d%d",&u_id, &p_id, &sco);
		if(sco > stu[u_id].score[p_id]){
            stu[u_id].flag = true;  
            if(sco == p[p_id]) stu[u_id].num++;
			stu[u_id].score[p_id] = sco;
			
		}
        else if(sco==-1 && stu[u_id].score[p_id]==-1){
            stu[u_id].score[p_id] = 0;
        }
	}
	for(int i=1; i<=n; i++){
		for(int j=1; j<=k; j++){
			if(stu[i].score[j]!=-1){
				stu[i].sum += stu[i].score[j];
			}		
		}
	}

	sort(stu+1, stu+n+1, cmp);  //00001 - N号选手排序
	int r = 1;
	for(int i=1; i<=n && stu[i].flag; i++){
		if(i>1 && stu[i].sum!=stu[i-1].sum){
			r = i;
		}
		printf("%d %05d %d",r,stu[i].id,stu[i].sum );
		for(int j=1; j<=k; j++){
			if(stu[i].score[j]!=-1){
				printf(" %d",stu[i].score[j] );
			}
			else{
				printf(" -");
			}
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值