HDU_1075_What Are You Talking About(字典树)

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 15100    Accepted Submission(s): 4850



Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
  
  
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
  
  
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended.
 
题意:作者遇到了美腻的Mars小姐,但是苦逼的是他听不懂她说的话,于是Mars小姐给他一本Mars-English字典。现在给出好多对English-Mars单词对,要你把Mars句子翻译成英文。Space(' '), tab('\t'), enter('\n')还有标点符号不要翻译,还有不能翻译的火星文也不要翻译。
分析:直接利用字典树求解,句子中处理出单词花点心思即可。
题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1075
代码清单:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX = 27 ;
const int maxn = 30005 ;
const int Max = 1000005;
struct trie{
    int point;
    trie *next[MAX];
};

trie *root=new trie();
char s[maxn],ss[MAX];
char anStr[Max][15];
int slen,k=1,ak,aj;

void createTrie(char *s,int pose){
    trie *p=root,*q;
    int len=strlen(s),pos;
    for(int i=0;i<len;i++){
        pos=s[i]-'a';
        if(p->next[pos]==NULL){
            q=new trie();
            q->point=0;
            for(int j=0;j<MAX;j++)
                q->next[j]=NULL;
            p->next[pos]=q;
            p=p->next[pos];
        }
        else{
            p=p->next[pos];
        }
    }
    p->point=pose;   //字符串结尾标志,并且大小为单词所在数组下标。
}

int findTrie(char *s){
    trie *p=root;
    int len=strlen(s),pos;
    for(int i=0;i<len;i++){
        pos=s[i]-'a';
        if(p->next[pos]==NULL)
            return 0;
        p=p->next[pos];
    }
    return p->point;
}

void delTrie(trie *Root){
    for(int i=0;i<MAX;i++){
        if(Root->next[i]!=NULL)
            delTrie(Root->next[i]);
    }
    free(Root);
}

int main(){
    for(int i=0;i<MAX;i++)
        root->next[i]=NULL;
    while(gets(s)){
        if(strcmp(s,"END")==0) break;
        if(strcmp(s,"START")==0) continue;
        slen=strlen(s);
        for(int i=0;i<slen;i++){
            if(s[i]==' '){
                aj=i+1;
                break;
            }
            anStr[k][i]=s[i];
        }
        ak=0;
        for(;aj<slen;aj++) ss[ak++]=s[aj];
        createTrie(ss,k);
        k++;
        memset(ss,'\0',sizeof(ss));
    }
    while(gets(s)){
        if(strcmp(s,"END")==0) break;
        if(strcmp(s,"START")==0) continue;
        slen=strlen(s);
        ak=0,aj=0;
        for(int i=0;i<slen;i++){
            if((s[i]>='a'&&s[i]<='z')||s[i]=='\''){
                ss[ak++]=s[i];
                aj=0;
            }
            else{
                if(!aj){
                    int judge=findTrie(ss);
                    if(judge) printf("%s",anStr[judge]);
                    else printf("%s",ss);
                    memset(ss,'\0',sizeof(ss));
                    ak=0;
                }
                aj++;
                printf("%c",s[i]);
            }
        }printf("\n");
    }
    delTrie(root);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值