poj 1703(并查集)

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20441 Accepted: 6052

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source



题目类型:并查集

题目描述:一个城市中只有两个犯罪团伙,告诉你某个罪犯和某个罪犯不在一个团伙。然后问你两个罪犯之间的关系。

题目分析:既然只有两个团伙,那么罪犯不在这个团伙就在那个团伙中。用 foe[i] 记录第一个与 i 不在一个团伙的人的 id。
这样如果a,b不在一个团伙,那么a和foe[b]肯定在一个团伙,同理b和foe[a]肯定在一个团伙。接下来就非常简单了,同一个集合中的元素团伙一样,把团伙一样的集合合并。


代码如下:
#include <iostream>
#include <stdio.h>
#define N 100005
using namespace std;

int rank[N];
int foe[N];
int f[N];
int n;
void init(){
    for(int i = 1; i <= n ; i++){
        rank[i] = 0;
        foe[i] = -1;
        f[i] = i;
    }
}

int find(int x){
    if( x == f[x]) {
        return x;
    } else {
        return f[x] = find(f[x]);
    }
}


void merge(int a, int b){
    int ra = find(a);
    int rb = find(b);
    if(ra != rb){
        if(rank[ra] < rank[rb]){
            f[ra] = rb;
        } else {
            f[rb] = ra;
            if(rank[rb] == rank[ra]){
                rank[ra]++;
            }
        }
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){

        int m;
        scanf("%d%d",&n,&m);
        init();

        char command;
        int a;
        int b;
        for(int i = 0; i < m;i++){
            getchar();
            command = getchar();
            scanf("%d%d",&a,&b);
            if( command == 'A') {
                if( find(a) == find(b)){
                    printf("In the same gang.\n");
                } else {
                    if( foe[a] == -1 || foe[b] == -1 || find(a) != find(foe[b])){
                        printf("Not sure yet.\n");
                    } else {
                        printf("In different gangs.\n");
                    }
                }

            } else {
                if(foe[a] == -1){
                    foe[a] = b;
                }
                if(foe[b] == -1){
                    foe[b] = a;
                }
                merge(a,foe[b]);
                merge(b,foe[a]);
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值