poj 2236(并查集)

Wireless Network
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 11583 Accepted: 4926

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source




题目类型:并查集

题目描述:有一个无线网络,网络由n个节点组成。如果节点a与节点b距离不超过d,那么节点a和节点b可以直接通信。
如果节点a可以与c通信,节点b也可以与c通信,那么节点a和b也可以通信。由于余震导致所有节点全部坏掉。
现在有两种操作,一种是修复某节点。一种是查询两个节点是否可以通信。

题目分析:图连通问题。由于是动态图用搜索不太合适。
把图中的点划分为n个集合,同一集合中的点连通。
如果两个点连通,把他们所在集合并在一起。
这样判断两个点是否连通,只需要看他们在不在同一集合就可以。


代码如下:


#include <iostream>
#include <stdio.h>
#include <math.h>
#define N 1002
using namespace std;

struct Point{
    int x;
    int y;
};
Point p[N];
int f[N];
int rank[N];
int n;
int d;
bool well[N];

void make_set(){
    for(int i = 1; i <= n; i++){
        rank[i] = 0;
        f[i] = i;
        well[i] = false;
    }
}
int find_root(int x){
    if(x == f[x]){
        return x;
    } else {
        f[x] = find_root(f[x]);
        return f[x];
    }
}
void merge(int a,int b){
    int ra = find_root(a);
    int rb = find_root(b);
    if(ra != rb){
        if(rank[ra] < rank[rb]){
            f[ra] = rb;
        } else {
            f[rb] = ra;
            if(rank[ra] == rank[rb]){
                rank[ra]++;
            }
        }
    }
}
bool checkD(Point a,Point b){
    int l = ceil(sqrt(  (double) ((a.x-b.x) * (a.x-b.x) + (a.y-b.y)*(a.y-b.y)) ));
    if( l <= d){
        return true;
    } else {
        return false;
    }
}


int main()
{

    scanf("%d%d",&n,&d);
    make_set();
    int x,y;
    for(int i = 1; i <= n; i++){
        scanf("%d%d",&x,&y);
        p[i].x = x;
        p[i].y = y;
    }
    getchar();
    char ch;
    int a,b;
    while( ch = getchar(), ch != -1){
        if( ch == 'O'){
            scanf("%d",&a);
            getchar();
            well[a] = true;
            for(int i = 1; i <= n; i++){
                if( well[i] && checkD(p[a],p[i])) {
                    merge(i,a);
                }
            }
        } else {
            scanf("%d%d",&a,&b);
            getchar();
            if( find_root(a) == find_root(b)){
                printf("SUCCESS\n");
            } else {
                printf("FAIL\n");
            }
        }
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值