L - Polynomial Integration HUST - 1575

本文介绍了一个使用编程解决微积分中多项式积分问题的方法。通过输入多项式的系数和次数,程序能够快速计算出指定区间内的积分值,显著提高了计算效率。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

//水题靠经验,一直wa,心疼
I guess that everybody has learned the course Calculus(微积分). To tell you the truth, I hate what course because of the endless exercise to do! My teacher was so strict that he assigned many exercise about polynomial integration to me. In each problem, he just gave me a polynomial f(x), starting point xs and ending point xt, and I must calculate the value of . I don’t want to waste my time on that, I need a efficient program to help me calculating that! My dear friend, can you help me?
Input
The first line of input contains an integer T, indicating test cases.
In each test case, the first line consist of 3 integers: n, xs, xt. N means that f(x) consists of n blocks:
Then following N lines of input, each line consists two integers: ai and di, representing the coefficient and degree of the i-th part of f(x), respectively.
1 <= n <= 10,
1 <= xs <= xt <= 100,
-3 <= di <= 3,
0 <= ai <= 20.
Output
In each test case, the output contains one line.
The only one line is formatted as “Case #X: Y”, where X is the test case number (starting with 1), Y is the result of , rounded to three decimal points.
Sample Input
2
2 1 2
2 1
3 2
1 1 5
1 0
Sample Output
Case #1: 10.000
Case #2: 4.000

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<cctype>
using namespace std;
const int MAX = 999999;
const double Eps = 1e-12;
const double PI = acos(-1.0);
int gcd(int x, int y)
{
    return x%y == 0 ? y : gcd(y, x%y);
}
struct node
{
    double a, b;
}num[100];
int main()
{
    int t;
    double sum;
    while (cin >> t)
    {
        for (int j = 1; j <= t; j++)
        {
            sum = 0;
            double n, da, dt;
            cin >> n >> da >> dt;
            for (int i = 0; i < n; i++)
                cin >> num[i].a >> num[i].b;
            for (int i = 0; i < n; i++)
            {
                if (num[i].b >= 0)
                {
                    double aa = num[i].a, bb = num[i].b;
                    num[i].a = aa / (bb + 1);
                    num[i].b = bb + 1;
                    sum += num[i].a*(pow(dt, num[i].b) - pow(da, num[i].b));
                }
                else
                {
                    if (num[i].b == -1)
                        sum += num[i].a*(log(dt) - log(da));
                    else
                    {
                        double aa = num[i].a, bb = num[i].b;
                        num[i].a = aa / (bb + 1);
                        num[i].b = bb + 1;
                        sum += num[i].a*(pow(dt, num[i].b) - pow(da, num[i].b));
                    }
                }

            }
            printf("Case #%d: %.3lf\n", j, sum);
        }
    }
    return 0;
}
这里写代码片
内容概要:本文详细介绍了基于结构不变补偿的电液伺服系统低阶线性主动干扰抑制控制(ADRC)方法的实现过程。首先定义了电液伺服系统的基本参数,并实现了结构不变补偿(SIC)函数,通过补偿非线性项和干扰,将原始系统转化为一阶积分链结构。接着,设计了低阶线性ADRC控制器,包含扩展状态观测器(ESO)和控制律,用于估计系统状态和总干扰,并实现简单有效的控制。文章还展示了系统仿真与对比实验,对比了低阶ADRC与传统PID控制器的性能,证明了ADRC在处理系统非线性和外部干扰方面的优越性。此外,文章深入分析了参数调整与稳定性,提出了频域稳定性分析和b0参数调整方法,确保系统在参数不确定性下的鲁棒稳定性。最后,文章通过综合实验验证了该方法的有效性,并提供了参数敏感性分析和工程实用性指导。 适合人群:具备一定自动化控制基础,特别是对电液伺服系统和主动干扰抑制控制感兴趣的科研人员和工程师。 使用场景及目标:①理解电液伺服系统的建模与控制方法;②掌握低阶线性ADRC的设计原理和实现步骤;③学习如何通过结构不变补偿简化复杂系统的控制设计;④进行系统仿真与实验验证,评估不同控制方法的性能;⑤掌握参数调整与稳定性分析技巧,确保控制系统在实际应用中的可靠性和鲁棒性。 阅读建议:本文内容详尽,涉及多个控制理论和技术细节。读者应首先理解电液伺服系统的基本原理和ADRC的核心思想,然后逐步深入学习SIC补偿、ESO设计、控制律实现等内容。同时,结合提供的代码示例进行实践操作,通过调整参数和运行仿真,加深对理论的理解。对于希望进一步探索的读者,可以关注文中提到的高级话题,如频域稳定性分析、参数敏感性分析等,以提升对系统的全面掌控能力。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值