L - Polynomial Integration HUST - 1575

本文介绍了一个使用编程解决微积分中多项式积分问题的方法。通过输入多项式的系数和次数,程序能够快速计算出指定区间内的积分值,显著提高了计算效率。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

//水题靠经验,一直wa,心疼
I guess that everybody has learned the course Calculus(微积分). To tell you the truth, I hate what course because of the endless exercise to do! My teacher was so strict that he assigned many exercise about polynomial integration to me. In each problem, he just gave me a polynomial f(x), starting point xs and ending point xt, and I must calculate the value of . I don’t want to waste my time on that, I need a efficient program to help me calculating that! My dear friend, can you help me?
Input
The first line of input contains an integer T, indicating test cases.
In each test case, the first line consist of 3 integers: n, xs, xt. N means that f(x) consists of n blocks:
Then following N lines of input, each line consists two integers: ai and di, representing the coefficient and degree of the i-th part of f(x), respectively.
1 <= n <= 10,
1 <= xs <= xt <= 100,
-3 <= di <= 3,
0 <= ai <= 20.
Output
In each test case, the output contains one line.
The only one line is formatted as “Case #X: Y”, where X is the test case number (starting with 1), Y is the result of , rounded to three decimal points.
Sample Input
2
2 1 2
2 1
3 2
1 1 5
1 0
Sample Output
Case #1: 10.000
Case #2: 4.000

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<cctype>
using namespace std;
const int MAX = 999999;
const double Eps = 1e-12;
const double PI = acos(-1.0);
int gcd(int x, int y)
{
    return x%y == 0 ? y : gcd(y, x%y);
}
struct node
{
    double a, b;
}num[100];
int main()
{
    int t;
    double sum;
    while (cin >> t)
    {
        for (int j = 1; j <= t; j++)
        {
            sum = 0;
            double n, da, dt;
            cin >> n >> da >> dt;
            for (int i = 0; i < n; i++)
                cin >> num[i].a >> num[i].b;
            for (int i = 0; i < n; i++)
            {
                if (num[i].b >= 0)
                {
                    double aa = num[i].a, bb = num[i].b;
                    num[i].a = aa / (bb + 1);
                    num[i].b = bb + 1;
                    sum += num[i].a*(pow(dt, num[i].b) - pow(da, num[i].b));
                }
                else
                {
                    if (num[i].b == -1)
                        sum += num[i].a*(log(dt) - log(da));
                    else
                    {
                        double aa = num[i].a, bb = num[i].b;
                        num[i].a = aa / (bb + 1);
                        num[i].b = bb + 1;
                        sum += num[i].a*(pow(dt, num[i].b) - pow(da, num[i].b));
                    }
                }

            }
            printf("Case #%d: %.3lf\n", j, sum);
        }
    }
    return 0;
}
这里写代码片
内容概要:本文详细介绍了施耐德M580系列PLC的存储结构、系统硬件架构、上电写入程序及CPU冗余特性。在存储结构方面,涵盖拓扑寻址、Device DDT远程寻址以及寄存器寻址三种方式,详细解释了不同类型的寻址方法及其应用场景。系统硬件架构部分,阐述了最小系统的构建要素,包括CPU、机架和模块的选择与配置,并介绍了常见的系统拓扑结构,如简单的机架间拓扑和远程子站以太网菊花链等。上电写入程序环节,说明了通过USB和以太网两种接口进行程序下载的具体步骤,特别是针对初次下载时IP地址的设置方法。最后,CPU冗余部分重点描述了热备功能的实现机制,包括IP通讯地址配置和热备拓扑结构。 适合人群:从事工业自动化领域工作的技术人员,特别是对PLC编程及系统集成有一定了解的工程师。 使用场景及目标:①帮助工程师理解施耐德M580系列PLC的寻址机制,以便更好地进行模块配置和编程;②指导工程师完成最小系统的搭建,优化系统拓扑结构的设计;③提供详细的上电写入程序指南,确保程序下载顺利进行;④解释CPU冗余的实现方式,提高系统的稳定性和可靠性。 其他说明:文中还涉及一些特殊模块的功能介绍,如定时器事件和Modbus串口通讯模块,这些内容有助于用户深入了解M580系列PLC的高级应用。此外,附录部分提供了远程子站和热备冗余系统的实物图片,便于用户直观理解相关概念。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值