hdu 2374

A Game with Marbles
Time Limit: 1000msMemory Limit: 32768KB This problem will be judged on HDU. Original ID: 2374
64-bit integer IO format: %I64d Java class name: Main
Prev Submit Status Statistics Next
Type:
None

Tag it!
There are n bowls, numbered from 1 to n. Initially, bowl i contains mi marbles. One game step consists of removing one marble from a bowl. When removing a marble from bowl i (i > 1), one marble is added to each of the first i-1 bowls; if a marble is removed from bowl 1, no new marble is added. The game is finished after each bowl is empty.

Your job is to determine how many game steps are needed to finish the game. You may assume that the supply of marbles is sufficient, and each bowl is large enough, so that each possible game step can be executed.

Input
The input contains several test cases. Each test case consists of one line containing one integer n (1 ≤ n ≤ 50), the number of bowls in the game. The following line contains n integers mi (1 ≤ i ≤ n, 0 ≤ mi ≤ 1000), where mi gives the number of marbles in bowl i at the beginning of the game.

The last test case is followed by a line containing 0.

Output
For each test case, print one line with the number of game steps needed to finish the game. You may assume that this number fits into a signed 64-bit integer.
Sample Input
10
3 3 3 3 3 3 3 3 3 3
5
1 2 3 4 5
0
Sample Output
3069
129
Source
题意看代码

#include <stdio.h>
__int64 a[1010], ans;
int main()
{
    int n, i, j;
    while(scanf("%d", &n) != EOF && n)
    {
        for (i = 1; i <= n; ++i)
        {
            scanf("%I64d", &a[i]);
        }
        ans = 0;
        for (i = n; i >= 1; --i)
        {
            ans += a[i];
            for(j = i- 1; j >=1; --j)
            {
                a[j] += a[i];
            }
        }
        printf("%I64d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值