hdu_3400_三分_求两条直线间的最小距离_经典二重三分

Line belt

In a two-dimensional plane there are two line belts, there are two segments AB and CD, lxhgww’s speed on AB is P and on CD is Q, he can move with the speed R on other area on the plane.
How long must he take to travel from A to D?
Input
The first line is the case number T.
For each case, there are three lines.
The first line, four integers, the coordinates of A and B: Ax Ay Bx By.
The second line , four integers, the coordinates of C and D:Cx Cy Dx Dy.
The third line, three integers, P Q R.
0<= Ax,Ay,Bx,By,Cx,Cy,Dx,Dy<=1000
1<=P,Q,R<=10
Output
The minimum time to travel from A to D, round to two decimals.
Sample Input
1
0 0 0 100
100 0 100 100
2 2 1
Sample Output
136.60

题意:
在二维坐标系中给两个线段,求从线段ab的a端到线段cd d端的最小距离,ab上的速度为v1 cd速度为v2 ,其它区域速度为v0;
思路:
在ab三分的到一个点,在在cd三分求一个点,这样两条线段就连起来,可以求最小距离,将ab上的一个点固定另一个点从 c到d 可以看出这是个凹函数;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
#define eps 1e-8
struct node
{
    double x,y;
} a,b,c,d;
double v1,v2,v0;
double dis(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double solve(node tt)
{
    node l,r;
    double s1,s2;
    l=c;
    r=d;
   do
    {
        node ll,rr;
        ll.x=(l.x+r.x)/2;
        ll.y=(l.y+r.y)/2;  
        rr.x=(ll.x+r.x)/2;
        rr.y=(ll.y+r.y)/2;
        s1=dis(tt,ll)/v0+dis(ll,d)/v2;
        s2=dis(tt,rr)/v0+dis(rr,d)/v2;
        if(s1>s2)
            l=ll;
        else r=rr;
    } while(dis(l,r)>=eps);
    return s1;
}
int main()
{
    int t,i,j;
    while(cin>>t)
    {
        while(t--)
        {
            cin>>a.x>>a.y>>b.x>>b.y>>c.x>>c.y>>d.x>>d.y;
            cin>>v1>>v2>>v0;
            node l=a,r=b;
            double s1, s2;
            do
            {
                node ll,rr;
                ll.x=(l.x+r.x)/2;
                ll.y=(l.y+r.y)/2;
                rr.x=(ll.x+r.x)/2;
                rr.y=(ll.y+r.y)/2;
                s1=dis(a,ll)/v1+solve(ll);
                s2=dis(a,rr)/v1+solve(rr);
                if(s1>s2)
                    l=ll;
                else r=rr;
            }while(dis(r,l)>=eps);
            printf("%.2lf\n",s1);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值