hdu_1060_数学求解n^n的第一位数

Leftmost Digit

Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
2
3
4
Sample Output
2
2
题意:
    求n^n的第一位数;
解:
    设 m=n^n;
       log10(m)=log10(n^n);
       log10(m)=n*log10(n);
       m=10(n*log10(n));
10的幂次方第一位一定是1,就要考虑它的小数位
//time º¯ÊýµÄʹÓÃ
#include<cstdio>
#include<iostream>
#include<ctime>
#include<algorithm>
#include<cmath>
clock_t st,ed;
double ans;

using namespace std;
typedef long long ll;
int x,y;
ll solve(ll a,ll b)
{
    ll ans=1;
    a%=10;
    while(b)
    {
        if(b&1)
            ans=ans*a%10;
        b>>=1;
        a=a*a%10 ;
    }
    return ans;
}
int main()
{
    ll t,a,b;
   /* for(int i=1;i<=15;i++)
    {
        cout<<i<<" "<<solve(i,i)<<endl;
    }*/
    while(cin>>t)
    {
        while(t--)
        {
            cin>>b;
            double t=b*log10(b*1.0);
            double point=t-(ll)t;
            int ans=pow(10.0,point);
            cout<<ans<<endl;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值