Catch That Cow

14 篇文章 0 订阅
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Example Input
5 17
Example Output
4

一道很纯粹的BFS,三个方向,可是,,,做这道题的时候,我RE了八次啊QAQ(哭死,原因是没控制好范围,越界了,,,
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;
const int N = 1e5 + 3;

int n, k;
struct node
{
    int i, step;
};
int vis[N];

int BFS(int x)
{
    queue<node> q;
    struct node t;
    t.i = x;
    t.step = 0;
    vis[x] = 1;
    q.push(t);
    while(!q.empty())
    {
        t = q.front();
        q.pop();
        if(t.i == k)
            return t.step;
        struct node u;
        u.i = t.i + 1;
        u.step = t.step + 1;
        if(!vis[u.i])
        {
            q.push(u);
            vis[u.i] = 1;
        }
        u.i = t.i - 1;
        u.step = t.step + 1;
        if(u.i >= 0 && !vis[u.i])     //控制下标非负
        {
            q.push(u);
            vis[u.i] = 1;
        }
        u.i = t.i * 2;                //下标乘二,很容易越界
        u.step = t.step + 1;
        if(u.i <= N && !vis[u.i])     //控制范围
        {
            q.push(u);
            vis[u.i] = 1;
        }
    }
}
int main()
{
    memset(vis, 0, sizeof(vis));
    scanf("%d%d", &n, &k);
    if(n > k)
        printf("%d", n-k);
    else
        printf("%d", BFS(n));
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值