A计划

14 篇文章 0 订阅
可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。

Input 输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小N*M(1 <= N,M <=10)。T如上所意。接下去的前N*M表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。
Output 如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。
Sample Input
1
5 5 14
S*#*.
.#...
.....
****.
...#.

..*.P
#.*..
***..
...*.
*.#..
Sample Output
YES

感觉题目描述的不太清楚吧,,一开始以为是T秒刚好找到公主,WA了两发,注意,传送到另一层的时候,那边不能是*和#,好像就这些

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;
const int N = 12;

struct node
{
    int x, y, layer, time;   //骑士所在的位置,层次,时间
};
int n, m, t;
char map[2][N][N];
bool vis[2][N][N];
int xx[4] = {1, 0, 0, -1};
int yy[4] = {0, 1, -1, 0};

int BFS()
{
    queue<node> q;
    struct node p, next;
    memset(vis, 0, sizeof(vis));
    p.x = 0;
    p.y = 0;
    p.layer = 0;
    p.time = 0;
    q.push(p);
    vis[0][0][0] = 1;
    while(!q.empty())
    {
        p = q.front();
        q.pop();
        if(map[p.layer][p.x][p.y] == 'P' && p.time <= t)  
            return 1;    
        for(int i = 0; i < 4; i++)
        {
            next.x = p.x + xx[i];
            next.y = p.y + yy[i];
            next.layer = p.layer;
            next.time = p.time + 1;
            if(next.x >= 0 && next.x < n && next.y >= 0 && next.y < m && !vis[next.layer][next.x][next.y])
            {
                vis[next.layer][next.x][next.y] = 1;                                                    
                if(map[next.layer][next.x][next.y] == '#')
                {
                    next.layer = 1 - next.layer;  //切换层次
                    if(map[next.layer][next.x][next.y] != '*' && map[next.layer][next.x][next.y] != '#')
                        q.push(next);
                }
                else if(map[next.layer][next.x][next.y] == '.' || map[next.layer][next.x][next.y] == 'P')                                  
                    q.push(next);  
            }
        }
    }
    return 0;
}
int main()
{
    int c;
    scanf("%d", &c);
    while(c--)
    {
        scanf("%d%d%d", &n, &m, &t);
        for(int k = 0; k < 2; k++)
            for(int i = 0; i < n; i++)
                scanf("%s", map[k][i]);
        if(BFS())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值