Silver Cow Party Dijkstra

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X

Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.


Output

Line 1: One integer: the maximum of time any one cow must walk.


Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4

4 2 3


Sample Output

10

题意还是很清楚的,就是求一头牛去和回来所花时间的最大值,由于道路是单向的,回来的时候是标准的迪杰,那去的时候呢,我们可以把目的地看成起点,然后把道路翻转,就可以用迪杰求最小值了

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 1010;
const int INF = 0x3f3f3f3f;

int g1[N][N], g2[N][N];   //g1是牛回家的图,g2是牛去参加派对的图
int d1[N], d2[N];        //d1是每头牛回家的最短距离,d2是每头牛去参加派对的最短距离
bool vis[N];
int n, m, x;

void Dijkstra(int g[N][N], int d[], int s)
{
    memset(vis, 0, sizeof(vis));
    d[s] = 0;
    for(int i = 1; i <= n; i++)
    {
        int u = -1, MIN = INF;
        for(int j = 1; j <= n; j++)
        {
            if(!vis[j] && d[j] < MIN)
            {
                u = j;
                MIN = d[j];
            }
        }
        if(u == -1) return;
        vis[u] = 1;
        for(int v = 1; v <= n; v++)
        {
            if(g[u][v] != INF && !vis[v] && d[u] + g[u][v] < d[v])
                d[v] = d[u] + g[u][v];
        }
    }
}
int main()
{
    int u, v, w;
    memset(g1, 0x3f, sizeof(g1));
    memset(g2, 0x3f, sizeof(g2));
    memset(d1, 0x3f, sizeof(d1));
    memset(d2, 0x3f, sizeof(d2));
    scanf("%d%d%d", &n, &m, &x);
    for(int i = 0; i < m; i++)
    {
        scanf("%d%d%d", &u, &v, &w);
        g1[u][v] = w;
        g2[v][u] = w;   //道路翻转
    }
    Dijkstra(g1, d1, x);
    Dijkstra(g2, d2, x);
    int MAX = 0, sum;
    for(int i = 1; i <= n; i++)
    {
        sum = 0;
        sum += d1[i] + d2[i];
        if(sum > MAX)
            MAX = sum;
    }
    printf("%d\n", MAX);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值