HDU 1541 star 树状数组

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2250    Accepted Submission(s): 858


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0



这道题的难点在于如何用树状数组来存各个坐标星星的等级。

题意已说明输入的的时候是按Y坐标从小到大排序的,然后可以用一个数组来根据横坐标的大小来记录这个点的星星的的等级。

首先每次读入一个星星的位置后,在它属于的等级的个数+1,然后要更新它之后的横坐标的等级。

#include <cstdio>
#include <iostream>
#include <string.h>
#include <vector>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
using namespace std;
int lev[32005];
int sum[32005];

int lowbit( int x )
{
    return x&(-x);    
}

int num( int x )
{
    int s = 0;
    while( x > 0 )
    {
           s += sum[x];
           x -= lowbit( x );       
    }
    return s;
}

void update( int x )
{
     while( x < 32005 )
     {
            sum[x]++;
            x += lowbit(x);       
     }
}

int main( )
{
    int n,x,y;
    while( ~scanf("%d",&n) )
    {
           memset( lev , 0 , sizeof(lev) );
           memset( sum , 0 , sizeof(sum) );
           for( int i=0 ; i<n ; i++ ){
                scanf("%d%d",&x,&y);
                ++lev[ num(x+1) ];
                update(x+1);
           }
           for( int i=0 ; i<n ; i++ )
                printf("%d\n",lev[i]);
    }
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值