迷宫城堡
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4223 Accepted Submission(s): 1835
Problem Description
为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。
Input
输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。
Output
对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。
Sample Input
3 3 1 2 2 3 3 1 3 3 1 2 2 3 3 2 0 0
Sample Output
Yes No
题意很明显,就是求强连通
如果最后求出来只有一个强连通分量,那么就说明所有点之间可以互相到达,即输出"Yes",否则输出"No"
测评情况(HDU OJ)
C++ AC Code
#include<cstdio>
#include<cstring>
#include<stack>
using namespace std;
const int N=10000+10;
int n,m;
struct link{int y;link *next;}*head[N];
stack<int> st;
bool hash[N],inst[N];
int dfstime;
int low[N],now[N];
int number;
void inlink(int x,int y)
{
link *node=new link;
node->y=y;
node->next=head[x];
head[x]=node;
}
void dfs(int x)
{
now[x]=low[x]=++dfstime;
hash[x]=true;st.push(x);inst[x]=true;
for(link *node=head[x];node;node=node->next)
{
int y=node->y;
if(!hash[y])
{
dfs(y);
low[x]=min(low[x],low[y]);
}
else if(inst[y]) low[x]=min(low[x],now[y]);
}
if(now[x]==low[x])
{
while(!st.empty())
{
int u=st.top();st.pop();
inst[u]=false;
if(u==x) break;
}
number++;
}
}
void tarjan()
{
for(int i=1;i<=n;i++) if(!hash[i]) dfs(i);
if(!st.empty())
{
while(!st.empty())
{
int u=st.top();st.pop();
inst[u]=false;
}
number++;
}
}
void work()
{
for(int i=1;i<=m;i++)
{
int x,y;
scanf("%d%d",&x,&y);
inlink(x,y);
}
tarjan();
if(number==1) puts("Yes");
else puts("No");
}
int main()
{
freopen("hdu1269.in","r",stdin);
freopen("hdu1269.out","w",stdout);
while(scanf("%d%d",&n,&m)==2&&n+m)
{
number=dfstime=0;
memset(hash,0,sizeof(hash));
memset(now,0,sizeof(now));
memset(low,0,sizeof(low));
memset(head,0,sizeof(head));
work();
}
return 0;
}