poj 2001 字典树问题

Shortest Prefixes
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10183 Accepted: 4303

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

分析:本题大意是输入n个字符串,然后给每个字符串缩写,缩写的规则是尽可能短的字符串前缀表达字符串本身。但是这个前缀有个要求就是他不可以包含在剩下的n-1个字符的前缀中。比如 safe  sade,safe的前缀有 s sa saf safe,我们可以用这四个前缀表达safe但是是s sa包含在sade中所以我们只可以用saf作为safe的缩写。也有特殊情况 比如 sa   safe  ,sa这个字符串的所有前缀都包含在safe中我们就认为sa自己是自己的缩写。
有上分析我们很快联想到解决前缀的很多算法这里重点推荐oms!!算法字典树(有些童鞋不知道这题怎么输入和测试输入就用while(cin》)想得出结果时就按ctrl+z回车两次就ok了)

#include <iostream>
#include <cstring>
using namespace std;

char word[1001][22];

struct node
{
	int icount;
	node* next[26];
	node()
	{
		for (int i = 0; i< 26; i++)
		{
			next[i] = NULL;
		}
		icount = 1;
	}
};
void insert(node* t, char* s1, int len)
{
	int i;
	node* a = t;
	node* b;
	for(i = 0; i< len; i++)
	{
		if (a->next[s1[i]-'a'] == NULL)
		{
			b = new node;
			a->next[s1[i]-'a'] = b;
		}
		else
		{
			a->next[s1[i]-'a']->icount++;
		}
		a = a->next[s1[i]-'a'];
	}
}
void acronym(node* t, char* a, int len)
{
	node* b;
	int i;
	for (i = 0; i < len; i++)
	{
		b = t->next[a[i]-'a'];
		if (b!=NULL && b->icount == 1)
		{
			break;
		}
		if (i == len-1)
		{
			break;
		}
		t  =b;
	}
	for (int j = 0; j <=i; j++)
	{
		cout<<a[j];
	}
	cout<<endl;
}
int main()
{
	node* trie = new node;
	node* t;
	int sum = 0;
	while (cin >> word[sum])
	{
		t = trie;
		insert(t, word[sum], strlen(word[sum]));
		sum++;
	}
	for (int i = 0; i< sum; i++)
	{
		t = trie;
		cout<<word[i]<<" ";
		acronym(t, word[i], strlen(word[i]));
	}
	return 0 ;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值