POJ 2001 Shortest Prefixes【字典树】题解

1.题目

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.

An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.
Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input
carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate
Sample Output
carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

2.代码

#define _CRT_SECURE_NO_WARNINGS   
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn = 26;
struct Trie
{
	Trie *Next[maxn];  //当前节点可以延伸出的边
	int flag;   
	Trie()  //函数,初始化以该信息为前缀的信息个数
	{
		flag = 1;
		memset(Next, NULL, sizeof(Next));
	}
}*root; //根节点
void insert(char *str)
{
	int len = strlen(str);
	Trie *p = root, *q;
	for (int i = 0; i < len; i++)
	{
		int id = str[i] - 'a';
		if (p->Next[id] == NULL)如果该节点指向的下一个节点为空(没有一条边延伸出去)
		{
			q = new Trie();   //新建一个节点
			p->Next[id] = q;  //存储节点
			p = p->Next[id];  ///指向该节点
		}
		else
		{
			p = p->Next[id];
			++(p->flag);  ///累加个数
		}
	}
}
int search(char *str)
{
	int len = strlen(str);
	Trie *p = root;
	for (int i = 0; i < len; i++)
	{
		int id = str[i] - 'a';
		p = p->Next[id];
		if (p == NULL) return 0;
	}
	return p->flag;
}
///释放
void free(Trie *T)
{
	if (T == NULL) return;
	for (int i = 0; i < maxn; i++)
	{
		if (T->Next[i])
		{
			free(T->Next[i]);
		}
	}
	delete(T);
}
int main()
{
	char str[20];
	root = new Trie(); //建立根节点
	while (gets(str))
	{
		if (str[0] == '\0') break;
		insert(str);
	}
	while (scanf("%s", str) != EOF)
	{
		printf("%d\n", search(str));
	}
	free(root);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林小鹿@

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值