Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Print the word "no" if not.
Sample Input
0 1 2 3 4 5
Sample Output
no no yes no no no
题目大意:
数组 F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (2<=n<1,000,000).输入一个数n,求F(n)是否为3的倍数。
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int a,b,c,d;
while(cin>>a)
{
if(a<=2)
{
if(a==2)
cout<<"yes"<<endl;
else
cout<<"no"<<endl;
}
else
{
if((a-2)%4==0)
{
cout<<"yes"<<endl;
}
else
cout<<"no"<<endl;
}
}
return 0;
}