HDU 2017 多校联赛4 1009 Questionnaire

Problem Description

In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training. 
这里写图片描述

Obviously many people don’t want more training, so the clever leader didn’t write down their words such as ”Yes” or ”No”. Instead, he let everyone choose a positive integer ai to represent his opinion. When finished, the leader will choose a pair of positive interges m(m>1) and k(0≤k< m), and regard those people whose number is exactly k modulo m as ”Yes”, while others as ”No”. If the number of ”Yes” is not less than ”No”, the leader can have chance to offer more training.

Please help the team leader to find such pair of m and k.

Input

The first line of the input contains an integer T(1≤T≤15), denoting the number of test cases.

In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of people in the ACM/ICPC team.

In the next line, there are n distinct integers a1,a2,…,an(1≤ai≤109), denoting the number that each person chosen.

Output

For each test case, print a single line containing two integers m and k, if there are multiple solutions, print any of them.

Sample Input



23 3 18 8 13 9

Sample Output

5 3

题目大意:

这是一个签到题,对2取余,看奇偶个数,奇数多输出2 1,偶数多输出2 0,一样多二者皆可。

c++

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int t,n;
    int a[100005];
    scanf("%d",&t);
    while(t--){
        int ans=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            if(a[i]%2==1)
                ans++;
        }
        if(ans>n/2){
            printf("2 1\n");
        }
        else{
            printf("2 0\n");
        }
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值