【PAT】1035 Password (20分)(模拟 STL vector)

题目:

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

题目大意:给出几个密码,其中,'1', '0', 'l', 'O'都是容易混淆的字符,如果密码中有这几个字符,就分别对应改为:'@', '%', 'L', 'o';若没有修改,则分为输入密码条数==1和>1的情况分别输出一句话即可。

解题思路:用string来保存id和密码,用两个char字符数组分别保存容易混淆的字符和这些字符需要被改变成什么字符,用一个flag来标识是否需要修改,循环查验每一个密码是否需要修改,然后将其修改。修改后的密码前面加上id后push进vector中,后遍历输出即可。

代码:

#include<iostream>
#include<vector>
using namespace std;
//string xiugai()
int main(){
  string id,pw;
  int n,cnt=0;
  //freopen("input.txt","r",stdin);
  cin>>n;
  int num=n;
	char a[] = {'1', '0', 'l', 'O'};
  char b[] = {'@', '%', 'L', 'o'};
  
  vector<string> v;
  while(n--){
    cin>>id>>pw;
    
    bool flag=false;//是否存在修改
    for(int i=0;i<pw.length();i++){
    	
      for(int j=0;j<4;j++){
        if(pw[i]==a[j]){
        //cout<<pw[i]<<"#";
          pw[i]=b[j];
          //cout<<pw[i]<<"#";
          flag=true;
          cnt++;//修改的人数
        }
      }
      
    }
    if(flag==true){
    	//string temp=pw;
      string temp=id+" "+pw;
      v.push_back(temp);
    }
  }
  if(cnt != 0) {
        printf("%d\n", v.size());
        for(int i = 0; i < v.size(); i++)
            cout << v[i] << endl;
    } else if(cnt==0&&num == 1) {//n在while变了 所以用num存起来了 
        printf("There is 1 account and no account is modified");
    } else {
        printf("There are %d accounts and no account is modified", num);
    }return 0;
}

其他人的优秀代码:

柳神:

https://www.liuchuo.net/archives/2063

解题思路:把需要改变的字符串改变后存储在字符串数组vector里面,根据数组里面元素的个数是否为0输出相应的结果

#include <iostream>
#include <vector>
using namespace std;
int main() {
    int n;
    scanf("%d", &n);
    vector<string> v;
    for(int i = 0; i < n; i++) {
        string name, s;
        cin >> name >> s;
        int len = s.length(), flag = 0;
        for(int j = 0; j < len; j++) {
            switch(s[j]) {
                case '1' : s[j] = '@'; flag = 1; break;
                case '0' : s[j] = '%'; flag = 1; break;
                case 'l' : s[j] = 'L'; flag = 1; break;
                case 'O' : s[j] = 'o'; flag = 1; break;
            }
        }
        if(flag) {
            string temp = name + " " + s;
            v.push_back(temp);
        }
    }
    int cnt = v.size();
    if(cnt != 0) {
        printf("%d\n", cnt);
        for(int i = 0; i < cnt; i++)
            cout << v[i] << endl;
    } else if(n == 1) {
        printf("There is 1 account and no account is modified");
    } else {
        printf("There are %d accounts and no account is modified", n);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值