HDU BillBoard(线段树)

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

 

Input

 

There are multiple cases (no more than 40 cases). The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

 

Output

 

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

 

Sample Input

 

3 5 5 2 4 3 3 3
 

 

Sample Output

 

1
2
1
3
-1
#include <bits/stdc++.h>
using namespace std;
const int MAXN = 200000;
struct Node
{
    int l;        // 当前子树包含的  最小行与最大行  l 为最顶层  r为最底层
    int r;
    int Max;     // Max 表示当前 子树 下 还能够保存的最大长度
} node[MAXN * 4];
// l 和 r 表示区间 此节点所管理的区间
// k 表示 元素下标
// w 表示 宽度
// 函数主要功能 构建树, 每个节点的初始化值一样
void InitTree(int l, int r, int k, int w)
{
    node[k].l = l;
    node[k].r = r;
    node[k].Max = w;
    if(l == r)
        return;
    int mid = (l + r) / 2;
    // 构建左子树
    InitTree(l, mid, 2 * k, w);
    // 构建右子树
    InitTree(mid + 1, r, 2 * k + 1, w);
}
// 参数v 表示要更新的值(既减少的值)
// 参数k 表示树的节点下标
void Update(int v, int k)
{
    if(node[k].l == node[k].r)  // 找到了需要放置的那一行
    {
        // 找到之后直接输出
        cout << node[k].l << endl;
        // 并且减少本节点 还能存的最大值
        node[k].Max -= v;
        return;
    }
    // 先找左子树 看看有没有哪一行 能放得下
    // 否则找右子树
    if(v <= node[2 * k].Max)
        Update(v, 2 * k);
    else
        Update(v, 2 * k + 1);
    // 回溯更新 找到节点能保存的最大值
    if(node[2 * k].Max > node[2 * k + 1].Max)
        node[k].Max = node[2 * k].Max;
    else
        node[k].Max = node[2 * k + 1].Max;
}
int main()
{
    int h, w, n;
    while(cin >> h >> w >> n) // 输入高度 宽度 数量
    {
        if(h > n) // 如果高度大于数量  优化为 一条广告一行  使有意义
            h = n;
        InitTree(1, h, 1, w); // 初始化树
        int tmp;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &tmp);
            // 注意:nodee[1] 树是根节点  更新的时候  从根结点向下找
            if(node[1].Max >= tmp)
                Update(tmp, 1);
            else
                printf("-1\n");
        }
    }
 return 0;
}

 

 
一开始错误理解,以为一个节点一个广告,没法把线段树和题意联系在一起,卡了好长时间。
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值