hdu billboard (线段树)

    
Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 
题意很简单:
        对于w*h的一块区域,连续摆放1*wi的木板,木板不能旋转,如果能放下就选择最靠上的位置摆放,输出行号,找不到输出-1。
       
思路:
        把高看成线段树的区间,w为对应区间点上的值,对于每次询问操作,如果当前节点的值小于给定值,直接返回-1。否则,如果
左子树的值大于给定值,访问左子树,否则访问右子树,一直到叶子节点。

代码:
#include<stdio.h>
#define maxn 200010
struct tree
{
    int num;
    int l,r;
}t[maxn*4];


int h,w,n;
void build(int id,int l,int r) 
{  
    t[id].l=l;
    t[id].r=r;
    t[id].num=w;
    if(l==r) 
        return ;
    int mid=(l+r)>>1;
    build(id<<1,l,mid);
    build(id<<1|1,mid+1,r);
}


int max(int a,int b)
{
    return a>b?a:b;
}


int find(int id, int val)
{
    if(t[id].l==t[id].r)  //查询到叶子节点,成功找到
    {
        if(t[id].num<val)
            return -1;
        t[id].num-=val;
        return t[id].l;
    }


    if(val<=t[id].num)
    {
        int x = 0;
        if(val<=t[id*2].num) 
           x=find(id<<1, val);
        else
           x=find(id<<1|1, val);
        t[id].num=max(t[id<<1].num,t[id<<1|1].num);   //递归更新内部节点
          return x;
    }
   else
        return -1;
}


int main()
{
    int i,x;
    while(scanf("%d%d%d",&h,&w,&n)!=EOF) 
   {
         if(h>n)   //这一步很重要,刚开始我忘了加,悲剧地RE······
            h=n;
        build(1,1,h);
         for(i=0;i<n;i++)
        {
            scanf("%d",&x);
            printf("%d\n",find(1,x));
        }
   }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值