Hdu-Billboard

题目名称:Billboard

题目链接:Billboard

Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 &lt; = &lt;= <= h,w &lt; = &lt;= <= 10^9 ; 1 &lt; = &lt;= <= n &lt; = &lt;= <= 200,000 ) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 &lt; = &lt;= <= wi &lt; = &lt;= <= 1 0 9 10^9 109) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.

Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1

题目大意

有一个宽h长w的广告栏,现在要按照尽量靠上靠左的原则贴宽为1长为 q的广告,请问应该贴到哪一行,如果贴不上则输出 “-1”

解题思路

简单的线段树问题,毕竟每一行的可用宽度可以用一个整型来表示,所以在这里就按照广告栏的高度为界限建立线段树,第一次提交程序runntime error,参考别人的博客后发现是线段树界限设置的问题,改为高度或广告总数的最小值即可

完整代码

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
#define N 210000
struct Node{
	int l,r,val;
}node[N<<2];
int h,w,n;

void build(int l,int r,int i){   //线段树创建模板
	node[i].l=l;
	node[i].r=r;
	node[i].val=w;
	if(l==r) return ;
	int mid=(l+r)>>1;
	build(l,mid,i<<1);
	build(mid+1,r,i<<1|1);
} 

int query(int k,int i){      //查询
	if(node[i].l==node[i].r) {
		node[i].val-=k;
		return node[i].l;
	}
	int ans;
	if(node[i<<1].val>=k){                        //按照最上方最左边的原则进行粘贴
		ans=query(k,i<<1);
	}else{
		ans=query(k,i<<1|1);
	}
	node[i].val=max(node[i<<1].val,node[i<<1|1].val);   //剩下的空间
	return ans;
}

int main()
{
	int k;
	while(~scanf("%d%d%d",&h,&w,&n)){
		h=min(h,n);
		build(1,h,1);
		for(int i=0;i<n;i++){
			cin>>k;
			if(k>node[1].val) printf("-1\n");    //如果大于所剩的空间,则直接无解
			else printf("%d\n",query(k,1));
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值