HDOJ 1013 Digital Roots(大数)

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58524    Accepted Submission(s): 18278


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
  
  
24 39 0
 

Sample Output
  
  
6 3
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1017  1012  1018  1048  1016

就是一个大数求和问题,我竟然。。。
第一次用整型,WA了
第二次没初始化,WA了
第三次AC:

#include<stdio.h>
#include<string.h>
int main(){
	char a[10000];
	int la,b[10000],sum,i;
	while(scanf("%s",a)&&strcmp(a,"0")!=0){
		la=strlen(a);
		sum=0;//各位数和 
		for(i=0;i<la;i++){
			b[i]=a[i]-'0';//字符转数字 
			sum+=b[i];//一个个求和 
			if(sum>=10)//超过10,最多18 
			sum=sum%10+sum/10;//两位数再加起来 
		}
		printf("%d\n",sum);
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
	}
	return 0;
}

根数:公式为b=(a-1)%9+1

java:
import java.io.*;
import java.math.*;
import java.util.*;
public class big2 {
	public static void main(String[] args){
		Scanner input=new Scanner(System.in);
		while(input.hasNext()){
			String num=input.next();
			if(num.equals("0"))
				break;
			BigInteger big=new BigInteger(num);
			BigInteger sum=big.add(new BigInteger("-1"));
			sum=sum.mod(new BigInteger("9"));
			sum=sum.add(BigInteger.ONE);
			System.out.println(sum);
		}
	}
}





 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值