HDU 1013 Digital Roots (大数,数论-九余数定理)

 

Digital Roots

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 86514    Accepted Submission(s): 27021

 

 

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

 

 

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

 

 

Output

For each integer in the input, output its digital root on a separate line of the output.

 

 

Sample Input

 

24390

Sample Output

 

63

Source

Greater New York 2000

题目连接:hud 1013 Digital Roots

题目大意:

已知有个数字,把它的没一位的数字加起来,如果和>=10,重复这个操作,直到它们的和变成一位数。并输出这个数。

样例例分析:

24->2+4 =6       (6<10)->输出6

39-->3+9=12     (12>10) ->1+2=3 (3<10)->输出3;

分析;(两种方法)

    这道题操作虽然简单,也好写,但是有坑点;输入的这个数非常大,远远超过long long的范围,因此用字符串来读入;

方法一:暴力求解

 

#include <iostream>
#include <cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
int main()
{
    string  n;
    ll sum;
    while(cin>>n){
        sum=0;
        if(n.size()==1&&n[0]=='0')        break;
        else{
            for(int i=0;i<n.size();i++)    sum+=n[i]-'0';
            if(sum<10)
                cout<<sum<<endl;
            else{
                while(sum){
                    ll x;  x=sum;      sum=0;
                        while(x){
                            sum+=x%10;
                            x/=10;
                        }
                    if(sum<10){
                        cout<<sum<<endl;   break;}
                }
            }

        }
    }
    return 0;
} 

方法二:数论--九余数定理

九余数的定理:一个数对9取余等于这个数各位数相加的和对9取余,例如 123 %9 = (1+2+3)%9,然后也可以知道0-9(不包括0和9)任何数除9的余数都是等于本身比如:4%9=4.。所以想求数根,用九余数是很方便的。比如一个大于9的数除以9的余数,这个余数相当于0-9之间的某数除以9的余数(九余数定理)又因为4%9=4这个定理。更加确定树根即其余数

代码如下

#include <iostream>
#include <cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
int main()
{
    string  n;
    ll sum;
    while(cin>>n){
        sum=0;
        if(n.size()==1&&n[0]=='0')
            break;
        else{
            for(int i=0;i<n.size();i++)
                sum+=n[i]-'0';
            if(sum<10)
                cout<<sum<<endl;
            else
                if(sum%9==0)
                    cout<<"9"<<endl;
                else
                    cout<<sum%9<<endl;
        }
    }
    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值