杭电1018 Big Number (求阶乘结果的位数)

题目要求:

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17761    Accepted Submission(s): 7964


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 


 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 


 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 


 

Sample Input
  
  
2 10 20
 


 

Sample Output
  
  
7 19

 

题目分析:

      本题要求计算一个数的阶乘后结果的位数,由于数据很大,所以完全计算出来再去数总共多少位,显然,不仅会超时,也会越界。n! 的位数=(int) log10(n!) + 1

其中(int) log10(n!)=(int)[log10(1)+log10(2)+log10(3)+……log10(n)];

简单的如此求,显然效率太差,很大程度上会超时

有公式如下:

(int) log10(n!)=log10(sqrt(2*PI*n))+n*log10(n/e);

 

其中PI =(double)acos((double)(-1));

e=(double)exp((double)1);

 

代码如下:

#include<iostream>
#include<cmath>
using namespace std;
const double PI=acos((double)(-1));
const double e=exp((double)1);

int main()
{
	int t,n;
	double num;
	cin>>t;
	while(t--)
	{
		cin>>n;
		num=log10(sqrt(2*PI*n))+n*log10(n/e);
		num+=1;
		cout<<(int)num<<endl;
	}
	return 0;
}


 

 

总结:

注意数学公式的应用!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值