Problem Description
通过本题目的练习可以掌握类的友元函数的定义和用法
要求设计一个点类Point,它具有两个double型的数据成员x,y。为该类设计构造函数。并为其添加一个友元函数用于计算并输出两点间的距离;再添加一个输出成员函数用于输出点的信息。
并编写主函数,实现以下的输入输出内容。
Input
4个double型的数,中间用一个空格间隔。
Output
输出数据共3行,前两行用于显示要求距离的两个点的信息,第三行显示两点的距离。
Example Input
5 6 2 3
Example Output
The first point is the coordinate:X=5,Y=6 The second point is the coordinate:X=2,Y=3 The distance between the two points is:4.24264
Hint
Author
黄晶晶
#include <iostream>
#include <cmath>
using namespace std;
class Point
{
private:
double x,y;
public:
friend void display1(Point &p1,Point &p2)//友元函数可以调用私有成员
{
cout<<"The distance between the two points is:"<<sqrt((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y))<<endl;
}
Point(double a,double b)
{
x=a;
y=b;
}
void display()
{
cout<<"point is the coordinate:X="<<x<<","<<"Y="<<y<<endl;
}
};
//可以先声明,类外调用void display1(Point &p1,Point &p2)
int main()
{
double a,b,c,d;
cin>>a>>b>>c>>d;
Point p1(a,b);
cout<<"The first ";
p1.display();
Point p2(c,d);
cout<<"The second ";
p2.display();
display1(p1,p2);
return 0;
}