【pta 甲级】1008 Elevator (20 分)

1008 Elevator (20 分)
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:
For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41

哎,还是题意理解有问题,一开始想的是所有人在0楼上电梯,request list里面是里面人要下的楼层,并且最后电梯会返回。然后就用set存储数据,用max=*(a.rbegin())得到set里面的最大值,然后进行的计算。后面又好好读了题之后,明白题目的意思就是让你老老实实的算就是了,但想当然的以为连续遇到相同数的时候还是只停一次, 比如 2 2 2 的结果和 1 2一样都是17.但怎么都有几个是答案错误,后来去看了别人的代码才知道
2 2 2 的结果是22。。…。也是不想说什么了。。。
代码写得有点复杂了

#include<bits/stdc++.h>
using namespace std;
// void i2s(long long x,string & str)
// {
//     stringstream ss;
//     ss<<x;
//     ss>>str;
// }
int main()
{
    int n;
    int a[120];
    cin>>n;
    for(int i=0 ;i<n;i++){
        cin>>a[i];
    }
    int min=0;
    int m=1;
    int i=0;
 
    min=a[i]*6;

    while(i<n-1){
        i++;
        if(a[i]==a[i-1])
            min+=5;
        if(a[i]<a[i-1])
        {
            min+=(a[i-1]-a[i])*4;
            m++;
        }
        if(a[i]>a[i-1]){
            min+=(a[i]-a[i-1])*6;
            m++;
        }
    }
    min=min+m*5;
    cout<<min;




    return 0;
}
如果是按照我第一次的理解
    // int b;
//     set<int>a;
//     int n;
//     cin>>n;
//     for(int i=0 ;i<n;i++)
//     {
//         cin>>b;
//         a.insert(b);
//     }
//     // cout<<a.size();
//     // for(auto x:a)
//     // {
//     //     cout<<x<<endl;
//     // }
//   int min=0;
// //   cout<<*a.rbegin();
//   int m=*a.rbegin();
//   min=(m)*6+5*a.size();
//   cout<<min<<endl;


别人的代码,简单易懂
#include<cstdio>
int main()
{
	int stay=0,t;
	int N,i,total=0;
	scanf("%d",&N);
	for(i=0;i<N;++i)
	{
		scanf("%d",&t);
		if(t==stay)
		{
			total+=5;
			continue;
			
		}
		if(t>stay)
			total+=(t-stay)*6+5;
		else
			total+=(stay-t)*4+5;
		stay=t;
	}
	printf("%d",total);
	return 0;
} 
————————————————
版权声明:本文为CSDN博主「漂流瓶jz」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/qq278672818/article/details/55113447
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值