Oil Deposits (hdu Problem-1241)

题目链接:

Oil Deposits

                                                                     Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                 Total Submission(s): 33494    Accepted Submission(s): 19463


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
   
   
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
   
   
0 1 2 2

题目大意:

首先输入m,n,表示m行n列的一张地图。其中有‘@’和‘*’,‘@’表示此地有油,‘*’边说此地没有油。题目要求计算出地图内有几个油田。需要注意的是:与‘@’相邻(八个方向,左右相邻、上下相邻、对角线)的‘@’属于同一个个油田。例如:

* *  *  *                          @ *  *  *                          *  @  *  *
*@@*         或              * @ *   *          或           *  @  *  *
* *  *  *                          *   * @  *                         *   *   *  * 

表示地图内只有一个油田。

解题思路:

定义一个二维数组(全局变量,保证qq函数也能改变二维数组的值),用于存储地图。然后用两个for循环,对每一个‘@’进行遍历,若遇到‘@’,则sum++,然后调用qq函数,该函数的功能为:搜索该‘@’的八个方向,把 与该‘@’相邻的‘@’变为‘*’。最终的sum便存储的是油田的个数。

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
char ch[101][101];
int n,m;
void qq(int x,int y) //该函数把 与‘@’相邻的‘@’ 全部标记为‘*’
{
    int dx,dy;   //dx、dy两个变量用于表示该点的八个方向
    ch[x][y]='*'; //搜索过的地方标记为‘*’
    for(int i=-1;i<=1;i++)
    {
        for(int j=-1;j<=1;j++) //两个for循环用于用于表示 与该点相邻的 八个方向(上、下、左、右、对角线)
        {
            dx=x+i;
            dy=y+j;
            if(dx>=1&&dx<=n&&dy>=1&&dy<=m&&ch[dx][dy]=='@')//如果八个方向中有:不越界并且为油田的点,则递归调用,进入该点对应的八个方向的那一层
                qq(dx,dy);
        }
    }
}
int main()
{
    memset(ch,'0',sizeof(ch)); //用memset函数把ch数组元素全部初始化为‘0’
    while(cin>>n>>m,m!=0) //输入
    {
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                cin>>ch[i][j];
            }
        }
        for(int i=1;i<=n;i++) //一个点一个点搜索
        {
            for(int j=1;j<=m;j++)
            {
                if(ch[i][j]=='@')
                {
                    sum++;
                    qq(i,j);
                }
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值