Oil Deposits(HDU-1241)

Problem Description

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

     For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0 

Sample Output

   0
   1
   2
   2

题意:给一个 n*m 的图,其中 @ 代表有油,* 代表已经开采,一片连续的 @ 视为一个油田,问油田个数

思路:求连八连通块个数,向 8 个方向深搜即可

Source Program

#include<cstring>
#include<iostream>
#include<cstdio>
using namespace std;

int m,n;
char mapp[105][105];
int direction[8][2]={{-1,0},{1,0},{0,-1},{0,1},{-1,-1},{-1,1},{1,-1},{1,1}};//方向向量

void dfs(int x0,int y0)
{
    int x,y;
    int i;

    for(i=0;i<8;i++)
    {
        x=x0+direction[i][0];
        y=y0+direction[i][1];

        if(x>=0&&x<m&&y>=0&&y<n)//判断是否越界
        {
            if(mapp[x][y]=='@')//判断是否有
            {
                mapp[x][y]='*';//开采
                dfs(x,y);//继续深搜
            }
        }
    }
}
int main()
{
    int sum;
    int i,j;

    while(cin>>m>>n)//输入地图大小
    {
        if(m==0)    break;

        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
                cin>>mapp[i][j];

        sum=0;//计数器归零
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                if(mapp[i][j]=='@')//如果有油
                {
                    mapp[i][j]='*';//开采
                    dfs(i,j);//进行深搜
                    sum++;
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值