[数论] HOJ 1528/ZOJ 1823 Factoring Large Numbers

传送门:Factoring Large Numbers

Factoring Large Numbers

Time Limit: 2 Seconds       Memory Limit: 65536 KB

One of the central idea behind much cryptography is that factoring large numbers is computationally intensive. In this context one might use a 100 digit number that was a product of two 50 digit prime numbers. Even with the fastest projected computers this factorization will take hundreds of years.

You don't have those computers available, but if you are clever you can still factor fairly large numbers.


Input

The input will be a sequence of integer values, one per line, terminated by a negative number. The numbers will fit in gcc's long long int datatype.


Output

Each positive number from the input must be factored and all factors (other than 1) printed out. The factors must be printed in ascending order, and followed by a single blank line.


Sample Input

90
1234567891
18991325453139
12745267386521023
-1


Sample Output

2
3
3
5

1234567891

3
3
13
179
271
1381
2423

30971
411522630413


Source:  University of Waterloo Local Contest 1996.09.28


解题报告:

首先一看没太看懂,再看才发现,原来就是因式分解。代码如下:

#include <stdio.h>
int main(){
    long long i,n;
    while(scanf("%lld",&n)==1&&n>=0){
        for(i=2;n>1;){
            if(n%i==0){
                printf("%lld\n",i);
                n/=i;
            }
            else{
                i++;
                if(i*i>n){
                    printf("%lld\n",n);
                    break;
                }
            }
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值