HDU ACM 1443 Joseph [数学题]

原题描述

Problem Description

The Joseph’s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, …, n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30

解题思路

题目大意:
约瑟夫环:有n个人围成一个圈,报数,杀死报到m的人。然后从他的下一个人继续开始报数,杀死报到m的人。直到剩下一个人。
假设有前k个是好人,后k个是坏人。
求一个最小的m,使得能够在不杀死好人的情况下先杀死所有的坏人。
思路:
每一个k都用枚举法计算出相应的m值,然后打表。

参考代码

/*
    HDU ACM 1443: Joseph
    by: Scarb
    2016-3-2
*/
#include <iostream>
using namespace std;

int k, m;
int jose[14];

int test(int k, int m)
{
    int cnt = 0;            // 杀死人数
    int sum = 2 * k;        // 总人数
    int index = m % sum;    // 序号
    if (index == 0) index = sum;    // 序号是0则表示队尾

    while (index > k)       // 当序号表示的人是坏人
    {
        sum--;              // 总人数减1
        index = (index + m - 1) % sum;      // 找到下一个出列的人的序号
        if (index == 0)
            index = sum;
        cnt++;              // 杀死这个人
    }
    return cnt;
}

int calc(int k)
{
    for (int i = k + 1;;i++)
    {
        if (test(k, i) == k)
            return i;
    }
}

void init()
{
    for (int i = 1; i < 14;i++)
    {
        jose[i] = calc(i);
    }
}

int main()
{
    init();

    while (cin >> k, k != 0)
    {
        cout << jose[k] << endl;
    }
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值