Julyed(记单词 不相信AC的一道题)

  Julyed is preparing for her CET-6. She has N words to remember, but there is only M days left. If she can’t remember all these words, she won’t pass CET-6. If she can’t pass CET-6, she will be unhappy. But if she remember too many words in one day, she will be unhappy, too. If she is unhappy, tomriddly will be unhappy. So she will remember as little words as she can in one day. For the happiness of both tomriddly and Julyed, how many words at most will Julyed remember in one day?

Input

 Multiple test cases. The first line is an integer T (T <= 10000), indicating the number of test cases.

Each test case is a line with two integers N, M (1 <= N, M <= 200), indicating the number of words to remember and the number of days left.

Output

 One line per case, an integer indicates the answer.

Sample Input

5
6 3
2 1
1 2
5 2
4 3

Sample Output

2
2
1
3
2

 

 

看的题目样例直接打的代码 然后就AC 了

代码如下

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int t,m,n,i;
    int x;
    while(scanf("%d",&t)!=EOF){
        for(i=0;i<=t-1;i++){
            scanf("%d %d",&m,&n);
            if(m%n==0)
                printf("%d\n",m/n);
            else{ x=m/n;
                x+=1;
                printf("%d\n",x);
            }
        }
    }
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值