HDU 2476 String painter (区间DP)

String painter

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3135    Accepted Submission(s): 1448


Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
 

Output
A single line contains one integer representing the answer.
 

Sample Input
  
  
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd
 

Sample Output
  
  
6 7
 

Source
 

Recommend
lcy
 


import java.util.Arrays;
import java.util.Scanner;

public class Main {
	static int[] a = new int[150];
	static int[][] dp = new int[150][150];
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		String s,ss;
		while(in.hasNext()){
			s = in.nextLine();
			ss = in.nextLine();
			Arrays.fill(a,0);
			int n=s.length();
			int inf = Integer.MAX_VALUE/3;
			for(int i=0;i<dp.length;i++)
				Arrays.fill(dp[i],0);
			for(int i=n;i>=1;i--){
				for(int j=i;j<=n;j++){
					dp[i][j] = dp[i+1][j]+1;
					for(int k=i+1;k<=j;k++){
						if(ss.charAt(k-1)==ss.charAt(i-1))dp[i][j]=Math.min(dp[i][j],dp[i+1][k]+dp[k+1][j]);
					}
				}
			}
			for(int i=1;i<=n;i++){
				a[i]=dp[1][i];
			}
			for(int i=1;i<=n;i++){
				if(s.charAt(i-1)==ss.charAt(i-1)){
					a[i]=a[i-1];
				}
				else{
					for(int j=1;j<i;j++)a[i]=Math.min(a[i],a[j]+dp[j+1][i]);
				}
			}
			System.out.println(a[n]);
			
			
			
		}

	}

}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值