1135. Is It A Red-Black Tree (30)
There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:
(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.
For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
|
|
|
|
|
|
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.
Input Specification:
Each input file contains several test cases. The first line gives a positive integer K (<=30) which is the total number of cases. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.
Output Specification:
For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.
Sample Input:3 9 7 -2 1 5 -4 -11 8 14 -15 9 11 -2 1 -7 5 -4 8 14 -15 8 10 -7 5 -6 8 15 -11 17Sample Output:
Yes No No
【分析】
给一个序列,先建一颗二叉排序树,然后判断这棵树是不是红黑树
红黑树判断:
1.根是黑色的
2.红色节点的儿子必须是黑色的
3.每个节点往下到达任意叶子的路径上通过的黑色节点数相同
这里有个小问题。。可能是我英语太差了 (3) Every leaf (NULL) is black. 这句话的意思是所有NULL节点都是黑色。。而不是所有叶子和NULL都是黑色
【代码】
#include <bits/stdc++.h>
using namespace std;
struct XX{
int l,r,val;
}a[100000];
int n;
void inser(int now,int id,int v)
{
//printf("%d%d",a[now].val,v);
if (abs(a[now].val)>abs(v)) //l
{
if (a[now].l == -1) a[now].l=id;
else inser(a[now].l,id,v);
}
else
{
if (a[now].r == -1) a[now].r = id;
else inser(a[now].r,id,v);
}
}
bool judge3(int now)
{
if (a[now].l == a[now].r && a[now].l == -1)
{
if (a[now].val>0) return true;
else return false;
}
if (a[now].l == -1) return judge3(a[now].r);
if (a[now].r == -1) return judge3(a[now].l);
return judge3(a[now].r) && judge3(a[now].l);
}
bool judge4(int now)
{
if (a[now].val < 0)
{
if (a[now].l!=-1 && a[a[now].l].val<0) return false;
if (a[now].r!=-1 && a[a[now].r].val<0) return false;
}
int flag = true;
if (a[now].l != -1) flag = flag && judge4(a[now].l);
if (a[now].r != -1) flag = flag && judge4(a[now].r);
return flag;
}
bool FFF;
int judge(int now)
{
int l1=0,l2=0;
if (a[now].l !=-1) l1=judge(a[now].l);
if (a[now].r !=-1) l2=judge(a[now].r);
if (l1!=l2)
{
FFF = false;
return -1;
}
l1+=a[now].val>0;
return l1;
}
int main()
{
int pp;scanf("%d",&pp);
while (pp--)
{
scanf("%d",&n);
memset(a,-1,sizeof(a));
scanf("%d",&a[0].val);
for (int i=1;i<n;i++)
{
int x;scanf("%d",&x);
a[i].val=x;
inser(0,i,x);
}
FFF = false;
if (a[0].val < 0) goto out;
//if (!judge3(0)) goto out;
if (!judge4(0)) goto out;
FFF = true;
judge(0);
out:;
if (FFF) puts("Yes");
else puts("No");
}
return 0;
}