Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1 100
Sample Output
1 5050
#include <stdio.h>
int i,sum,n;
int main()
{
//这题用公式做如果不作处理会数据溢出
//题目中有这样一句话
//You may assume the result will be in the range of 32-bit signed integer
//虽然说结果在32位整型以内,但是公式是n*(n+1)/2
//电脑在计算n*(n+1)的时候其实已经溢出了
//因此可以作以下处理(1和2取其一即可)
//1. 将 n 直接声明为 __int64 n;
//2. 公式变为 n/2.0 * (n+1)
while(scanf("%d",&n)!=EOF)
{
sum=0;
for(i=1;i<=n;i++)
{
sum+=i;
}
printf("%d\n\n",sum); //此次若用cout<<sum<<endl<<endl; 会出现operator << is ambiguous 错误 ,因为cout并没有对__int64的输出进行重载,要输出的话用printf("%d\n\n",sum)
return 0;
}