PAT A1060. Are They Equal (25)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3
感觉对于A级题,读懂题目是十分重要的。本题用到了STL中的String 。主要用到的是其在字符串中的定位和删除。然后还有分治的思想。
#include <cstdio>
#include <stdlib.h>
#include <algorithm>
#include <vector>
#include <cstring>
#include <math.h>
#include <string>
#include <iostream>
using namespace std;
#define Max 100010
int n;
string Deal_st(string a,int & e)
{
	int k=0;
	while (a.length() > 0  &&  a[0] == '0')
	{
		a.erase(a.begin());
	}
	if(a[0]=='.')//a为一个小于1的数
	{
        a.erase(a.begin());
		while (a.length() > 0 && a[0]=='0')
		{
			a.erase(a.begin());
			e--;
		}
	}
	else  //a大于1 
	{
		while (k<a.length()&&a[k]!='.'){
			k++;e++;
		}
		if(k<a.length())
		{
			a.erase(a.begin()+k);
		}
	}
	if(a.length()==0)
	{
		e=0;
	}
	int num=0;
	k=0;
	string res;
	while (num<n)
	{
		if(k<a.length()) res+=a[k++];
		else res+='0';
		num++;
	}
	return res;
}
int main()
{
	string num1,num2,num3,num4;
	cin>>n>>num1>>num2;
	int e1=0,e2=0;
	num3=Deal_st(num1,e1);
	num4=Deal_st(num2,e2);
	if(num3==num4&&e1==e2)
	{
		cout<<"YES 0."<<num3<<"*10^"<<e1<<endl;
	}
	else cout<<"NO 0."<<num3<<"*10^"<<e1<<" 0."<<num4<<"*10^"<<e2<<endl;
	system("pause");
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值