1060. Are They Equal (25)

102 篇文章 0 订阅
26 篇文章 0 订阅

1060. Are They Equal (25)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3
 
N小数部分的位数,数str[0] 数str[1];
看看两个在小数部分为N的计算机浮点储存的情况下,是不是相等。存储小数部分的第一位为非零,如果值是0的话,0.0……*10^0;

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月12日 23:16答案正确251060C++ (g++ 4.7.2)1308datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确11808/8
1答案正确13087/7
2答案正确13082/2
3答案正确11802/2
4答案正确13002/2
5答案正确11802/2
6答案正确13082/2

#include<iostream>  
#include<string>
using namespace std;  
void getmachine(int*e, string *str,int N)
{
  int dot = (*str).find('.')  ; 
  if (dot != -1)
  {
    str->erase(dot, 1);
      (*e) = dot; 
  }
  else(*e) = str->size(); 
  str->insert(0, "0.");
  dot = 2;
  while (str->size() > dot && (*str)[dot] == '0')
    dot++;
  dot -= 2;
  str->erase(2, dot);
  (*e) -= dot;
  dot = str->size();
  if (dot == 2)(*e) = 0;
  N += 2;
  if (dot >  N)str->erase(N, dot - N +1);
  else str->insert(dot, N - dot, '0');
}
int main()
{      
  string str[2];
  int e[2];
  int N;
  cin >> N >> str[0] >> str[1];
  getmachine(&e[0], &str[0],N);
  getmachine(&e[1], &str[1],N);
  if (e[0] == e[1] && str[0] == str[1])cout << "YES " << str[0] << "*10^" << e[0] << endl;
  else cout << "NO " << str[0] << "*10^" << e[0] << " " << str[1] << "*10^" << e[1] << endl;
  system("pause");
  return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值