甲级PAT 1148 Werewolf - Simple Version (20 分)(暴力求解)

1148 Werewolf - Simple Version (20 分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

题目要求 

狼人杀,一共有两只狼,其他都是平民,每个人指出其他一个人为平民还是为狼人,平民为正,狼人为负。平民和狼人中各有一个说谎,输出两只狼的编号(从1开始),如果有多种情况,输出最小的情况,如果无法判断出来,则输出No Solution

解题思路

每个人的指正情况用数组v来存储,v[k]代表第k个人的指正情况。

用一个数组a表示每个人的状态,1为平民,-1位狼人,循环遍历假设两个人为狼人,这样所有人的身份就确定下来了。

这样当v[k]!=a[abs(v[k])]*abs(v[k])时,就说明k撒了谎, a[abs(v[k])]代表第k个人指正的那个人abs(v[k])的真实身份。

如果有两个人撒谎,且这两个人一个是平民一个是狼人,则说明假的两个狼人成立,而且由于是从前往后遍历,所得的结果也是最小的,直接输出就好了

完整代码

#include<bits/stdc++.h>
using namespace std;

int main(){
	int n,i,j,k;
	cin>>n;
	vector<int> v(n+1);
	for(i=1;i<=n;i++) cin>>v[i];
	for(i=1;i<=n;i++){
		for(j=i+1;j<=n;j++){
			vector<int> lie,a(n+1,1);
			a[i]=a[j]=-1;
			for(k=1;k<=n;k++){
				if(v[k]!=a[abs(v[k])]*abs(v[k])) lie.push_back(k);
			}
			if(lie.size()==2 && a[lie[0]]+a[lie[1]]==0){
				cout<<i<<" "<<j;
				return 0;
			}
		}
	}
	cout<<"No Solution";
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值