GCD

Problem Description

Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.

Output

For each test case, print the number of choices. Use the format in the example.

Sample Input

2
1 3 1 5 1
1 11014 1 14409 9

Sample Output

Case 1: 9
Case 2: 736427

Hint

For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

Source

2008 “Sunline Cup” National Invitational Contest

思路:1~b内和1~d内中互素的个数,正常求解的话,肯定会超时,这时候我们可以求它的反面,即用容斥定理求,用总的个数减去1~b中与1~d中不互素的个数,另n为b,d中较小的那个,m为b,d中较大的那位,可以依次求出i(1<=i<=n)的素因子,那么在i+1~m内与s(s为k的因子)不互素的个数为m/s-i/s;
再根据奇减偶加的方法处理它;
代码如下:

#include<stdio.h>
#include<string.h>
int main()
{
    int a,b,c,d,k,t,n,m,x,cnt,p[1000];
    long long sum;
    scanf("%d",&t);
    for(int l=1;l<=t;l++)
    {
        scanf("%d %d %d %d %d",&a,&b,&c,&d,&k);
        if(k==0||k>b||k>d)
        {
            printf("Case %d: 0\n",l);
            continue;
        }
        b=b/k;
        d=d/k;
        n=b<=d?b:d;
        m=b>=d?b:d;//n为小的那位,m为大的那位;
        sum=m;
        for(int i=2;i<=n;i++)
        {
            sum=sum+m-i;
            x=i;
            cnt=0;
            memset(p,0,sizeof(p));
            for(int j=2;j*j<=x;j++)
            {
                if(x%j==0)
                {
                    p[cnt++]=j;
                    while(x%j==0)
                        x=x/j;
                }
            }
            if(x>1)
                p[cnt++]=x;
            for(long long j=1;j<(1<<cnt);j++)
            {
                long long s=1,l=0;
                for(int k=0;k<cnt;k++)
                {
                    if(j&(1<<k))
                    {
                        l++;
                        s=s*p[k];
                    }
                }
                s=m/s-i/s;
                if(l%2)
                    sum=sum-s;//减去奇数个素因子相乘
                else
                    sum=sum+s;//加上偶数个素因子相乘;
            }
        }
        printf("Case %d: %lld\n",l,sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值