Bombing(HDU-4022)

Problem Description
It’s a cruel war which killed millions of people and ruined series of cities. In order to stop it, let’s bomb the opponent’s base.
It seems not to be a hard work in circumstances of street battles, however, you’ll be encountered a much more difficult instance: recounting exploits of the military. In the bombing action, the commander will dispatch a group of bombers with weapons having the huge destructive power to destroy all the targets in a line. Thanks to the outstanding work of our spy, the positions of all opponents’ bases had been detected and marked on the map, consequently, the bombing plan will be sent to you.
Specifically, the map is expressed as a 2D-plane with some positions of enemy’s bases marked on. The bombers are dispatched orderly and each of them will bomb a vertical or horizontal line on the map. Then your commanded wants you to report that how many bases will be destroyed by each bomber. Notice that a ruined base will not be taken into account when calculating the exploits of later bombers.
 

Input
Multiple test cases and each test cases starts with two non-negative integer N (N<=100,000) and M (M<=100,000) denoting the number of target bases and the number of scheduled bombers respectively. In the following N line, there is a pair of integers x and y separated by single space indicating the coordinate of position of each opponent’s base. The following M lines describe the bombers, each of them contains two integers c and d where c is 0 or 1 and d is an integer with absolute value no more than 10 9, if c = 0, then this bomber will bomb the line x = d, otherwise y = d. The input will end when N = M = 0 and the number of test cases is no more than 50.
 

Output
For each test case, output M lines, the ith line contains a single integer denoting the number of bases that were destroyed by the corresponding bomber in the input. Output a blank line after each test case.
 

Sample Input
  
  
3 2 1 2 1 3 2 3 0 1 1 3 0 0
 

Sample Output
  
  
2 1
 
题目大意:由于xxx原因,我们要炸掉敌方基地,输入n(敌方基地个数)和m(我方轰炸机的个数),然后输入n个基地的坐标(x,y),输入c,d,如果c=0,将轰炸x=d的所有坐标,c=1,将轰炸y=d的所有坐标,输出每个轰炸机轰炸的个数;

代码如下:
#include<bits/stdc++.h>
using namespace std;
#define ma map<int,multiset<int> >
#define se multiset<int>
ma a,b;
void my_solve(se &r1,ma &r2,int d)
{
    int cnt=0;
    for(set<int>::iterator it=r1.begin();it!=r1.end();it++)
    {
        r2[*it].erase(d);
        cnt++;
    }
    r1.clear();
    cout<<cnt<<endl;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n!=0||m!=0))
    {
        int x,y;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            a[x].insert(y);
            b[y].insert(x);
        }
        for(int i=1;i<=m;i++)
        {
            int c,d,cnt=0;
            scanf("%d%d",&c,&d);
            if(c==0)
                my_solve(a[d],b,d);
            else
                my_solve(b[d],a,d);
        }
        printf("\n");
        a.clear();
        b.clear();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值